summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 19:11:18 -0500
committerSam James <sam@gentoo.org>2024-03-01 00:32:31 +0000
commitc9a290239287bf9a67b1e6ef31d50d8d95954fca (patch)
tree2206c5ddfe7366a0d70d81e8ea804cff7b7a53d6 /media-gfx
parentdev-ml/cryptokit: mark "mpir" use dependency as disabled-if-missing (diff)
downloadgentoo-c9a290239287bf9a67b1e6ef31d50d8d95954fca.tar.gz
gentoo-c9a290239287bf9a67b1e6ef31d50d8d95954fca.tar.bz2
gentoo-c9a290239287bf9a67b1e6ef31d50d8d95954fca.zip
media-gfx/meshlab: remove various totally erroneous dependencies
mpir: mpir is an ancient fork of gmp from 2017. It claims to be focused on speed. It doesn't build with modern compilers due to Modern C issues, and it fails to build with LTO as well. Unlike gmp, this will never be fixed. meshlab can look for either mpir or gmp, but we depended on BOTH and only gmp got used. mpir was completely extraneous. levmar: It would be great if we could use the system levmar, as meshlab genuinely depends on it. But it hardcodes a vendored copy: https://github.com/cnr-isti-vclab/meshlab/blob/bd88167db9839109487f401be50991c4bc990d27/src/external/levmar.cmake qhull: Currently, the build logs this: -- Could NOT find Qhull: missing: libqhull (found /usr/lib64/cmake/Qhull/QhullConfig.cmake (found version "8.0.2")) This happens because cmake is broken, probably. But meshlab 2021 ports to libqhull_r, which "should" work fine. Pity we are stuck in 2020 instead. We really could and should use the system copy but the build system cannot and does not detect it, which means we shouldn't be depending on something we cannot use. Bug: https://bugs.gentoo.org/905859 Bug: https://bugs.gentoo.org/812950 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/meshlab/meshlab-2020.12-r3.ebuild (renamed from media-gfx/meshlab/meshlab-2020.12-r2.ebuild)7
1 files changed, 3 insertions, 4 deletions
diff --git a/media-gfx/meshlab/meshlab-2020.12-r2.ebuild b/media-gfx/meshlab/meshlab-2020.12-r3.ebuild
index 3022559a4e4c..7350616490eb 100644
--- a/media-gfx/meshlab/meshlab-2020.12-r2.ebuild
+++ b/media-gfx/meshlab/meshlab-2020.12-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,6 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="double-precision minimal"
+# qhull: newer meshlab supports system re-entrant version
+# levmar: build system hardcodes vendored copy
DEPEND="
dev-cpp/eigen:3
dev-cpp/muParser
@@ -31,9 +33,6 @@ DEPEND="
media-libs/glew:0=
=media-libs/lib3ds-1*
media-libs/openctm:=
- media-libs/qhull:=
- sci-libs/levmar
- sci-libs/mpir:=
"
RDEPEND="${DEPEND}"