summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-07 21:10:55 +0100
committerSam James <sam@gentoo.org>2023-09-07 21:10:55 +0100
commitc3b73b38769ceea31eff9c730adfce9dd6d9e87f (patch)
tree704808d44578ac808f49606b6037b06de7a8a97e /media-libs/exempi
parentnet-dns/dnscrypt-proxy: Stabilize 2.1.5 ppc64, #913789 (diff)
downloadgentoo-c3b73b38769ceea31eff9c730adfce9dd6d9e87f.tar.gz
gentoo-c3b73b38769ceea31eff9c730adfce9dd6d9e87f.tar.bz2
gentoo-c3b73b38769ceea31eff9c730adfce9dd6d9e87f.zip
media-libs/exempi: add 2.6.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/exempi')
-rw-r--r--media-libs/exempi/Manifest1
-rw-r--r--media-libs/exempi/exempi-2.6.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/exempi/Manifest b/media-libs/exempi/Manifest
index c470d9f1e4a4..aaabbef1cecc 100644
--- a/media-libs/exempi/Manifest
+++ b/media-libs/exempi/Manifest
@@ -1,2 +1,3 @@
DIST exempi-2.6.2.tar.bz2 3709476 BLAKE2B 3b65db1f9e7c2bf050af6e273b8327d70e23d3321d3c280ddf8b36b467e2822b12f93cb14d8d342e2a2974a9b745f13fd98c79d9b67e634da5bc9b5ae71e4918 SHA512 c81c7a5bad1a294ce253d1471c00740679b7fb489658ead68a6892b701cc02a031a5dc69d70045a8276e1e19c716df88e92014df4c2809266a71ff05de9ad57a
DIST exempi-2.6.3.tar.xz 2842408 BLAKE2B a3deb86a12161f4a1b7c0bacc4e6b59a5e54df4e5c158b48c8d66dc968e5fb1e210a9fac73e85720b43e9090c38a7023e771054e63a57c618385bb02a525d89e SHA512 517dba7534ac6978083338d3c3bf184c9b0a56e625e714703da71b064b68a8872bdd66673be27a192e7e6a22b9acd8eb1ad447c2a807f564547e765c63fbd2b4
+DIST exempi-2.6.4.tar.xz 2843304 BLAKE2B 35ae01db243825eea05fe946a958be78ee75c3e6bc3cd02bf5596bd0c9543ccecb285c93e2533c7ceba1e42b25266834bddfd6eda4fef351b384298cc638cfb2 SHA512 86e41e24e34150f398dffe3219f1530fbf14606feeee9953395bfedb335316ec90ac88e2843f2c037a564909fc3cc82a5cce53edb18219663a1b454cda6bef72
diff --git a/media-libs/exempi/exempi-2.6.4.ebuild b/media-libs/exempi/exempi-2.6.4.ebuild
new file mode 100644
index 000000000000..e5669843463f
--- /dev/null
+++ b/media-libs/exempi/exempi-2.6.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Port of the Adobe XMP SDK to work on UNIX"
+HOMEPAGE="https://libopenraw.freedesktop.org/wiki/Exempi"
+SRC_URI="https://libopenraw.freedesktop.org/download/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="2/8"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/expat-2:=
+ sys-libs/zlib
+ virtual/libiconv
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-libs/boost )
+"
+BDEPEND="
+ sys-devel/autoconf-archive
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.2-iconv.patch
+ "${FILESDIR}"/${PN}-2.6.3-clang16-binary_function.patch
+)
+
+src_prepare() {
+ default
+
+ # Needed for autoconf 2.71
+ config_rpath_update .
+ eautoreconf
+}
+
+src_configure() {
+ # - --enable-static as --disable-static breaks build
+ # - Valgrind detection is "disabled" due to bug #295875
+ econf \
+ --enable-static \
+ $(use_enable test unittest) \
+ VALGRIND=""
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ emake -C samples/source distclean
+ rm samples/{,source,testfiles}/Makefile* || die
+ docinto examples
+ dodoc -r samples/.
+ fi
+
+ # --disable-static breaks tests
+ rm -rf "${ED}/usr/$(get_libdir)/libexempi.a" || die
+
+ find "${ED}" -name '*.la' -delete || die
+}