summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-03-17 21:53:34 +0300
committerSam James <sam@gentoo.org>2022-03-18 00:31:41 +0000
commit3bbfabcbf72ad21914c56e510158935e3bafbe89 (patch)
treeb10a0a20b4e664ca657361fab08283bc6926fc77 /media-libs/gst-rtsp-server
parentmedia-sound/pulseaudio: Add USE=aptx dependency on gst-plugins-openaptx (diff)
downloadgentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.tar.gz
gentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.tar.bz2
gentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.zip
media-libs/gstreamer: Version bump, 1.18.6
Bug: https://bugs.gentoo.org/835368 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24625 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gst-rtsp-server')
-rw-r--r--media-libs/gst-rtsp-server/Manifest1
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.18.6.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
index 047e94e048c5..6f6980482ac3 100644
--- a/media-libs/gst-rtsp-server/Manifest
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -1,3 +1,4 @@
DIST gst-rtsp-server-1.16.3.tar.xz 699472 BLAKE2B 8937ce9d0550b11657496dec5a79c00f74de4da9deb9236693a25f4e266a779c8d4f439b127c2af87c874327e10f01f6a1d74fc1cd1bd0eca20093341568cb82 SHA512 f9ca08cfef92b74a63279a5480cfc1b18557f3062aadc765dd4d3de57d62b9ddf3ca98a4680dcd0f050812128c5c03592cdbf9d8329b85a6c2f3a39209c07701
DIST gst-rtsp-server-1.18.4.tar.xz 358140 BLAKE2B 3c8dae60742cc35580d5dbb4bbc5175ee93de2d2bb64c0de0dd09df5137b2b1518f6a39a2538d1eca86e8bd756299cada6f26ae23f33e1af1d6317e1e30d9d63 SHA512 1cda671f43e608d89aa024a8b4a39cbe1b83e1cd822b1190c777dd18c2000b5c8370e50598821b9c3f348776a418286a26993acf4255c6ff488682e0addeefab
+DIST gst-rtsp-server-1.18.6.tar.xz 364472 BLAKE2B 7fe0f70130f2e8022cc9308e8bde1c889c918e34edcfb633c0edf4e674f1b88610ec975cf67aca123193a22025512afbd3d5ab71df6b3d69eea44e56fab30602 SHA512 11c637fe263a9a55820be51fc3cef0aef06af5dc06ab20786b804412ee16ca7abdf20261b10e7483accde390ba75a921b050ab7a2f737145780815cd47f8f5f8
DIST gst-rtsp-server-1.20.1.tar.xz 358032 BLAKE2B 53dc0936a6a67b75c636d5170549b10456a68679e7fb5cfc6ad5a9d3e56044ddd93bbe25353fdd9f102155d831de48e8dbecc0697b767f9c2e03e4c1d1460a4e SHA512 8f1cf76602e55fbeaa77cd757c2a1380a792909a53e00cb29a4978789f37ee56493ce3fcb652769cdd47ccb935bba0291908d16fa506b58bcc65f34d303ac963
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.18.6.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.18.6.ebuild
new file mode 100644
index 000000000000..470918b177f6
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.18.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs"
+
+# gst-plugins-base for many used elements and API
+# gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
+# gst-plugins-srtp for srtpenc and srtpdec elements
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc "${S}"/examples/*.c
+ fi
+}