summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-30 18:32:35 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-30 18:33:26 +0100
commit084870d5158c5b8122653844d3f202321c36455a (patch)
tree9067980f04c267b6feca6043dd3bd045be1641a3 /media-sound
parentmedia-sound/qmpdclient: Drop duplicated KEYWORDS (diff)
downloadgentoo-084870d5158c5b8122653844d3f202321c36455a.tar.gz
gentoo-084870d5158c5b8122653844d3f202321c36455a.tar.bz2
gentoo-084870d5158c5b8122653844d3f202321c36455a.zip
media-sound/qmpdclient: EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.2.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/qmpdclient/qmpdclient-1.2.2-r2.ebuild b/media-sound/qmpdclient/qmpdclient-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..412a266223dd
--- /dev/null
+++ b/media-sound/qmpdclient/qmpdclient-1.2.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit fdo-mime cmake-utils
+
+DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
+HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
+SRC_URI="http://dump.bitcheese.net/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS README THANKSTO )
+PATCHES=( "${FILESDIR}"/${P}-qt48.patch )
+
+src_prepare() {
+ sed -i -e "/^Categories/s/Network/AudioVideo/" ${PN}.desktop || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( "-DVERSION=${PV}" )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }