summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-10-24 12:30:05 -0300
committerPacho Ramos <pacho@gentoo.org>2024-11-08 17:32:11 +0100
commita8ddd723dc321970484801df8b7977ab9989ddca (patch)
treef2b3b2997fd3bf5f7607e0f03a3ef0313528aa41 /media-video
parentprofiles: update gnome-shell-46 mask (diff)
downloadgentoo-a8ddd723dc321970484801df8b7977ab9989ddca.tar.gz
gentoo-a8ddd723dc321970484801df8b7977ab9989ddca.tar.bz2
gentoo-a8ddd723dc321970484801df8b7977ab9989ddca.zip
media-video/totem: Bump to 43.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39099 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/totem/Manifest1
-rw-r--r--media-video/totem/files/43.1-gst-inspect-sandbox.patch31
-rw-r--r--media-video/totem/files/b17
-rw-r--r--media-video/totem/totem-43.1.ebuild127
4 files changed, 176 insertions, 0 deletions
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index c6fb95cdb95b..cce8a193171d 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -1 +1,2 @@
DIST totem-43.0.tar.xz 2486304 BLAKE2B 3b43ad2cbf40472bff3b7369001b9b7784ef52244812d9aae493fffa99982a8f24770d0f5063f0b1f1fd320d6b2cec5e702ded9ccfaece51f7bdf9d862b96230 SHA512 b35d32ebadf4b9900ab234f07f8a7128edbc15593e1447c22f3c7a653fcbd4a2df9d45484e2decce5dd5ab67849fca1003a1ded338a0af0930b6560ee4f764ae
+DIST totem-43.1.tar.xz 2545240 BLAKE2B 922991006540e04b6919e9d455e123f563703c0ef04575b7610b6a0369d4e7fd8583cc5e87f313e3c137d5231c9c598fa197c6d89ef2ffd3a334c3486f417148 SHA512 1cd6ccea8a6e379095d1974b095aa29d7c7d800028704d680300dffc4c69a8d60397cab10996ab1c2e8075be5f7ddbce1aa5207d63b1088d23a42d9cd597730f
diff --git a/media-video/totem/files/43.1-gst-inspect-sandbox.patch b/media-video/totem/files/43.1-gst-inspect-sandbox.patch
new file mode 100644
index 000000000000..12fcc7438001
--- /dev/null
+++ b/media-video/totem/files/43.1-gst-inspect-sandbox.patch
@@ -0,0 +1,31 @@
+# From abb91b315f407b7e180bc00eb96f1cd6bb0ab25d Mon Sep 17 00:00:00 2001
+# From: Gilles Dartiguelongue <eva@gentoo.org>
+# Date: Thu, 7 Jun 2018 23:47:48 +0200
+# Subject: [PATCH] Make gst-inspect calls optional at build-time
+#
+# Crashes on Gentoo due to plugins trying to access dri nodes which are sandboxed
+--- a/meson_options.txt 2024-10-22 13:04:07.000000000 -0300
++++ b/meson_options.txt 2024-10-24 12:18:11.291930982 -0300
+@@ -6,4 +6,5 @@
+ option('enable-gtk-doc', type: 'boolean', value: false, description: 'use gtk-doc to build documentation')
+ option('profile', type: 'combo', choices: ['default', 'development'], value: 'default', description: 'Build profiles')
+ option('inspector-page', type:'boolean', value: false, description: 'Whether to build the optional GTK inspector page')
++option('gst-inspect', type: 'boolean', value: true, description: 'build-time test of available gstreamer plugins')
+ option('ui-tests', type:'boolean', value: true, description: 'Whether to run tests that require a display')
+--- a/src/backend/meson.build 2024-10-22 13:04:07.000000000 -0300
++++ b/src/backend/meson.build 2024-10-24 12:25:43.591062855 -0300
+@@ -1,5 +1,6 @@
+ backend_inc = include_directories('.')
+
++if get_option('gst-inspect')
+ gst_inspect = find_program(
+ 'gst-inspect-1.0',
+ join_paths(gst_dep.get_pkgconfig_variable('toolsdir'), 'gst-inspect-1.0'),
+@@ -32,6 +33,7 @@
+ assert(r.returncode() == 0,
+ 'Cannot find required GStreamer-1.0 plugin "' + plugin + '". It should be part of gst-plugins-good. Please install it.')
+ endforeach
++endif
+
+ sources = files(
+ 'bacon-time-label.c',
diff --git a/media-video/totem/files/b b/media-video/totem/files/b
new file mode 100644
index 000000000000..05de6a6f614e
--- /dev/null
+++ b/media-video/totem/files/b
@@ -0,0 +1,17 @@
+--- /var/tmp/portage/media-video/totem-43.1/work/totem-43.1/src/backend/meson.build 2024-10-22 13:04:07.000000000 -0300
++++ /tmp/meson.build 2024-10-24 12:25:43.591062855 -0300
+@@ -1,5 +1,6 @@
+ backend_inc = include_directories('.')
+
++if get_option('gst-inspect')
+ gst_inspect = find_program(
+ 'gst-inspect-1.0',
+ join_paths(gst_dep.get_pkgconfig_variable('toolsdir'), 'gst-inspect-1.0'),
+@@ -32,6 +33,7 @@
+ assert(r.returncode() == 0,
+ 'Cannot find required GStreamer-1.0 plugin "' + plugin + '". It should be part of gst-plugins-good. Please install it.')
+ endforeach
++endif
+
+ sources = files(
+ 'bacon-time-label.c',
diff --git a/media-video/totem/totem-43.1.ebuild b/media-video/totem/totem-43.1.ebuild
new file mode 100644
index 000000000000..176491f25136
--- /dev/null
+++ b/media-video/totem/totem-43.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome.org gnome2-utils meson virtualx xdg python-single-r1
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="https://apps.gnome.org/Totem/ https://gitlab.gnome.org/GNOME/totem/"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="gtk-doc +python test"
+# see bug #359379
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.72.0:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=gui-libs/libhandy-1.5.0:1
+ >=media-libs/gstreamer-1.6.0:1.0
+ >=media-libs/gst-plugins-base-1.6.0:1.0[pango]
+ >=media-libs/gst-plugins-good-1.6.0:1.0
+ >=media-libs/grilo-0.3.0:0.3[playlist]
+ >=dev-libs/libpeas-1.1.0:0[gtk]
+ >=dev-libs/totem-pl-parser-3.26.5:0=[introspection]
+ gnome-base/gnome-desktop:3=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ >=dev-libs/gobject-introspection-1.54:=
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/grilo-plugins:0.3
+ media-plugins/gst-plugins-gtk:1.0[opengl]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ x11-themes/adwaita-icon-theme
+ dev-libs/libportal:0=[gtk]
+ python? (
+ x11-libs/pango[introspection]
+ >=dev-libs/libpeas-1.1.0:0[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-lang/perl
+ gtk-doc? ( >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.5 )
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# perl for pod2man
+# Prevent dev-python/pylint dep, bug #482538
+
+PATCHES=(
+ "${FILESDIR}"/"${PV}"-gst-inspect-sandbox.patch # Allow disabling calls to gst-inspect (sandbox issue)
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ # Drop pointless samplepython plugin from build
+ sed -e '/samplepython/d' -i src/plugins/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Denable-easy-codec-installation=yes
+ -Denable-python=$(usex python yes no)
+ -Dlibportal=enabled
+ -Dwith-plugins=all # in 3.34.1 only builtin and python plugins are left, and python is extra controlled by enable-python
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Dprofile=default
+ -Dinspector-page=false
+ -Dgst-inspect=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0= # bug 812170
+ meson_src_install
+ if use python ; then
+ python_optimize "${ED}"/usr/$(get_libdir)/totem/plugins/
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+src_test() {
+ virtx meson_src_test
+}