summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-20 16:30:55 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-20 16:30:55 +0200
commit2cefb7db913129009c3d7b9f555d11bba972da04 (patch)
treefa7f2582558ceae0dab834044e5027c9cfe15a76 /net-libs/libotr/libotr-4.1.1.ebuild
parentRevert "x11-misc/xdg-utils: Deps were keyworded at some point" (diff)
downloadgentoo-2cefb7db913129009c3d7b9f555d11bba972da04.tar.gz
gentoo-2cefb7db913129009c3d7b9f555d11bba972da04.tar.bz2
gentoo-2cefb7db913129009c3d7b9f555d11bba972da04.zip
net-libs/libotr: [QA] Do not install static archives
Closes: https://bugs.gentoo.org/465686 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/libotr/libotr-4.1.1.ebuild')
-rw-r--r--net-libs/libotr/libotr-4.1.1.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/net-libs/libotr/libotr-4.1.1.ebuild b/net-libs/libotr/libotr-4.1.1.ebuild
index ed4e3b66ff8c..ce15add6ba4e 100644
--- a/net-libs/libotr/libotr-4.1.1.ebuild
+++ b/net-libs/libotr/libotr-4.1.1.ebuild
@@ -12,8 +12,19 @@ SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-RDEPEND=">=dev-libs/libgcrypt-1.2:0
- dev-libs/libgpg-error"
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error:0="
DEPEND="${RDEPEND}"
-DOCS=( AUTHORS ChangeLog NEWS README UPGRADING )
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ dodoc UPGRADING
+
+ # no static archives, #465686
+ find "${D}" -name '*.la' -delete || die
+}