summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-12-17 10:46:27 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-12-17 10:53:21 +0100
commitba1a45a64740e78e055c829f1c153a27c64c7212 (patch)
treebcdb33df201514701e24cd17999bf60db8d6ee7d /net-misc/ipmiview
parentdev-java/jakartaee-migration: dropped obsolete 1.0.4 (diff)
downloadgentoo-ba1a45a64740e78e055c829f1c153a27c64c7212.tar.gz
gentoo-ba1a45a64740e78e055c829f1c153a27c64c7212.tar.bz2
gentoo-ba1a45a64740e78e055c829f1c153a27c64c7212.zip
net-misc/ipmiview: add 2.21.0.221118
Bug: https://bugs.gentoo.org/886199 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/ipmiview')
-rw-r--r--net-misc/ipmiview/Manifest1
-rw-r--r--net-misc/ipmiview/ipmiview-2.21.0.221118.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-misc/ipmiview/Manifest b/net-misc/ipmiview/Manifest
index ea2c262f1c5d..f2db45ea6ce9 100644
--- a/net-misc/ipmiview/Manifest
+++ b/net-misc/ipmiview/Manifest
@@ -1 +1,2 @@
DIST IPMIView_2.20.0_build.220309_bundleJRE_Linux_x64.tar.gz 151702450 BLAKE2B 11b47da54e414d110007aac9ab120182659c2eb4a39dcc5b141db68db9e7c70760ad477f4f21b697ccb8571c1585b6096c6e7c562c3e629865bb8504b3599292 SHA512 13f7e3b50ad95206c41b3153748dd6f5ac29947416c3cd2ae18d82e06afed107d15378bb398cf3d7e6ebaf7cfc08e413897e8847daf53194c16efae5e3393750
+DIST IPMIView_2.21.0_build.221118_bundleJRE_Linux_x64.tar.gz 152487572 BLAKE2B 3183a7eb48b476d5ba46d7bbb8e5e9287b5622f92474984c60580c4273fe077526e276d7b849011fd6e9fc2e7c170947ab6dafe64fa47ee1ee9b3c3b74318d3f SHA512 4e21bee8c81acc0afc33df34e10530157a09908957c3aad54b9f51ca71b83e79d1b52a804f18f34fb8bbfaf2574ab7a3b65d0f66495aa27284cd67baa387f737
diff --git a/net-misc/ipmiview/ipmiview-2.21.0.221118.ebuild b/net-misc/ipmiview/ipmiview-2.21.0.221118.ebuild
new file mode 100644
index 000000000000..0969639c5c31
--- /dev/null
+++ b/net-misc/ipmiview/ipmiview-2.21.0.221118.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop java-pkg-2 prefix
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="IPMIView"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="A GUI application that allows to manage multiple target systems through BMC"
+HOMEPAGE="https://www.supermicro.com/"
+SRC_URI="https://www.supermicro.com/wftp/utility/${MY_PN}/Linux/${MY_PN}_${MY_PV}_build.${MY_DATE}_bundleJRE_Linux_x64.tar.gz"
+
+LICENSE="supermicro"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ net-misc/stunnel
+ sys-libs/ncurses-compat:5
+ virtual/jre:1.8
+"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="bindist mirror"
+
+DIR="/usr/share/${PN}"
+QA_PREBUILT="usr/lib*"
+
+src_unpack() {
+ unpack ${A}
+ mv -v ${MY_PN}_${MY_PV}_build.${MY_DATE}_bundleJRE_Linux_x64 ${P} || die
+}
+
+src_prepare() {
+ default
+
+ # Extract icons for menu entries
+ unzip -j -LL IPMIView20.jar images/ipmi{view,trap}.ico || die
+
+ # Don't use their scary launchers
+ rm -v lax.jar || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+ java-pkg_doso *64.so
+
+ local pre=$(prefixify_ro "${FILESDIR}"/launcher-pre.bash)
+ java-pkg_dolauncher ipmiview --jar IPMIView20.jar -pre "${pre}"
+ java-pkg_dolauncher ikvm --jar iKVM.jar -pre "${pre}"
+ java-pkg_dolauncher ikvmmicroblade --jar iKVMMicroBlade.jar -pre "${pre}"
+ java-pkg_dolauncher jviewerx9 --jar JViewerX9.jar -pre "${pre}"
+ java-pkg_dolauncher trapreceiver --jar TrapView.jar -pre "${pre}"
+
+ exeinto ${DIR}/jre/bin
+ newexe $(prefixify_ro "${FILESDIR}"/fake-java-r1.bash) java
+
+ insinto ${DIR}/lib/BMCSecurity
+ doins BMCSecurity/*.{crt,key,pem,txt}
+
+ insinto ${DIR}/lib/BMCSecurity/linux
+ doins BMCSecurity/linux/stunnel.conf
+
+ dosym ../../../../../bin/stunnel ${DIR}/lib/BMCSecurity/linux/stunnel32
+ dosym ../../../../../bin/stunnel ${DIR}/lib/BMCSecurity/linux/stunnel64
+
+ doicon ipmi{view,trap}.ico
+ make_desktop_entry ipmiview IPMIView ipmiview.ico
+ make_desktop_entry trapreceiver "Trap Receiver" ipmitrap.ico
+
+ local DOCS=( *.pdf *.txt )
+ einstalldocs
+}