summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-15 21:12:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-15 22:20:41 +0100
commit5b146a49465814fa38af6cdbc4196b9c327b78c4 (patch)
tree63cb2bb7b6863b548d41dac9081fe91651b3cd5e /sci-mathematics/gappa
parentsci-mathematics/lean: drop old 4.2.0_rc4 (diff)
downloadgentoo-5b146a49465814fa38af6cdbc4196b9c327b78c4.tar.gz
gentoo-5b146a49465814fa38af6cdbc4196b9c327b78c4.tar.bz2
gentoo-5b146a49465814fa38af6cdbc4196b9c327b78c4.zip
sci-mathematics/gappa: bump to 1.4.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/gappa')
-rw-r--r--sci-mathematics/gappa/Manifest1
-rw-r--r--sci-mathematics/gappa/gappa-1.4.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-mathematics/gappa/Manifest b/sci-mathematics/gappa/Manifest
index 941d4322fa4c..7151d496042d 100644
--- a/sci-mathematics/gappa/Manifest
+++ b/sci-mathematics/gappa/Manifest
@@ -1 +1,2 @@
DIST gappa-1.4.1.tar.gz 388314 BLAKE2B 08bc38745fd33a892ef288315bb4eac730c96ddb379ec4689385b63a9f1f74a662bc303f8323bf3941875b6d38e988fe4114e0db84994a7e7a5858b178cc0026 SHA512 bae9788fdce92b04b011b9de207a1234215cbb68c8bd0a60d925fa5fb5e1cad014d60ed8b45d84e8fabd6b54a870a70af6dd24dd68f4dbb2e129f83dcf88fa11
+DIST gappa-1.4.2.tar.gz 395447 BLAKE2B 55d5e8a6376c3cce00fdf04c7e661ee14f5c04d883b445d1ff76e4ad8147a1d61fcbdd9685a882cfe7265841d4af90e21e1a315cf5ebdc656fd35f933b27c0f5 SHA512 aec04da1a478ecc876794b06a92a56ceb76ae2b1edd0da2a18cb509b3ae6f81437fe73777b7b05ef129edd8754528330f3f3a4713713c70934af3a6bdac4c7e5
diff --git a/sci-mathematics/gappa/gappa-1.4.2.ebuild b/sci-mathematics/gappa/gappa-1.4.2.ebuild
new file mode 100644
index 000000000000..7a69fe2ea262
--- /dev/null
+++ b/sci-mathematics/gappa/gappa-1.4.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER=doxygen
+DOCS_DIR=doc/doxygen
+
+inherit docs multiprocessing
+
+DESCRIPTION="Tool for verifying floating-point or fixed-point arithmetic"
+HOMEPAGE="https://gappa.gitlabpages.inria.fr/
+ https://gitlab.inria.fr/gappa/gappa/"
+SRC_URI="https://gappa.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="CeCILL-2 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS INSTALL.md NEWS.md README.md )
+
+src_compile() {
+ ./remake --jobs=$(makeopts_jobs) || die
+
+ docs_compile
+}
+
+src_test() {
+ ./remake --jobs=$(makeopts_jobs) check || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+
+ einstalldocs
+}