summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-03 23:53:45 +0000
committerSam James <sam@gentoo.org>2021-11-03 23:57:34 +0000
commit3fc4b39346b5346d6368a729a02ba7b1b9bf3ccb (patch)
tree0183fdd8bfb2c566aad5780fa4185144b22ee333 /sys-apps/systemd-tmpfiles
parentmail-client/thunderbird: restore keywords (diff)
downloadgentoo-3fc4b39346b5346d6368a729a02ba7b1b9bf3ccb.tar.gz
gentoo-3fc4b39346b5346d6368a729a02ba7b1b9bf3ccb.tar.bz2
gentoo-3fc4b39346b5346d6368a729a02ba7b1b9bf3ccb.zip
sys-apps/systemd-tmpfiles: fix build with meson-0.60
Closes: https://bugs.gentoo.org/821547 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/systemd-tmpfiles')
-rw-r--r--sys-apps/systemd-tmpfiles/files/systemd-tmpfiles-249.2-meson-0.60.patch26
-rw-r--r--sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild1
2 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/systemd-tmpfiles/files/systemd-tmpfiles-249.2-meson-0.60.patch b/sys-apps/systemd-tmpfiles/files/systemd-tmpfiles-249.2-meson-0.60.patch
new file mode 100644
index 000000000000..b931912be23e
--- /dev/null
+++ b/sys-apps/systemd-tmpfiles/files/systemd-tmpfiles-249.2-meson-0.60.patch
@@ -0,0 +1,26 @@
+https://github.com/systemd/systemd/commit/c29537f39e4f413a6cbfe9669fa121bdd6d8b36f
+https://bugs.gentoo.org/821547
+
+From: Dan Streetman <ddstreet@canonical.com>
+Date: Fri, 3 Sep 2021 12:43:33 -0400
+Subject: [PATCH] meson.build: change operator combining bools from + to and
+
+upstream meson stopped allowing combining boolean with the plus
+operator, and now requires using the logical and operator
+
+reference:
+https://github.com/mesonbuild/meson/commit/43302d3296baff6aeaf8e03f5d701b0402e37a6c
+
+Fixes: #20632
+--- a/meson.build
++++ b/meson.build
+@@ -35,7 +35,7 @@ conf.set10('BUILD_MODE_DEVELOPER', get_option('mode') == 'developer',
+
+ want_ossfuzz = get_option('oss-fuzz')
+ want_libfuzzer = get_option('llvm-fuzz')
+-if want_ossfuzz + want_libfuzzer > 1
++if want_ossfuzz and want_libfuzzer
+ error('only one of oss-fuzz or llvm-fuzz can be specified')
+ endif
+
+
diff --git a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild
index a651892d8e0b..ad80dc82cf86 100644
--- a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild
+++ b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-249.2.ebuild
@@ -62,6 +62,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
PATCHES=(
# backport from 250 to silence musl warnings
"${FILESDIR}/249-sys-include-posix.patch"
+ "${FILESDIR}/${P}-meson-0.60.patch"
)
python_check_deps() {