summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-01 06:26:20 +0000
committerSam James <sam@gentoo.org>2024-03-01 07:54:39 +0000
commit230e670ced81a0257c62cbd6d6f8441158fdcaa5 (patch)
tree0e2a1715d9e9acc1d16bb1e0062b485aa93c62c2 /sys-devel
parentsys-process/acct: update EAPI 7 -> 8, fix _F_S=3 crash, fix startup (diff)
downloadgentoo-230e670ced81a0257c62cbd6d6f8441158fdcaa5.tar.gz
gentoo-230e670ced81a0257c62cbd6d6f8441158fdcaa5.tar.bz2
gentoo-230e670ced81a0257c62cbd6d6f8441158fdcaa5.zip
sys-devel/lld: filter LTO (ODR violations)
Bug: https://github.com/llvm/llvm-project/issues/83529 Closes: https://bugs.gentoo.org/922353 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/lld/lld-17.0.6.ebuild3
-rw-r--r--sys-devel/lld/lld-18.1.0_rc3.ebuild3
-rw-r--r--sys-devel/lld/lld-18.1.0_rc4.ebuild3
-rw-r--r--sys-devel/lld/lld-19.0.0.9999.ebuild3
-rw-r--r--sys-devel/lld/lld-19.0.0_pre20240224.ebuild3
5 files changed, 15 insertions, 0 deletions
diff --git a/sys-devel/lld/lld-17.0.6.ebuild b/sys-devel/lld/lld-17.0.6.ebuild
index 628ca40e4df2..6b93f3ac17e8 100644
--- a/sys-devel/lld/lld-17.0.6.ebuild
+++ b/sys-devel/lld/lld-17.0.6.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
}
src_configure() {
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-18.1.0_rc3.ebuild b/sys-devel/lld/lld-18.1.0_rc3.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-18.1.0_rc3.ebuild
+++ b/sys-devel/lld/lld-18.1.0_rc3.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-18.1.0_rc4.ebuild b/sys-devel/lld/lld-18.1.0_rc4.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-18.1.0_rc4.ebuild
+++ b/sys-devel/lld/lld-18.1.0_rc4.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-19.0.0.9999.ebuild b/sys-devel/lld/lld-19.0.0.9999.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-19.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-19.0.0.9999.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-19.0.0_pre20240224.ebuild b/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
+++ b/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"