summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-21 19:05:53 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-21 19:08:58 -0400
commitac76c26fe0e368fc820a3aef4c8603becdda47c1 (patch)
tree882f4c4f1c2e3b332f07701aeb4c7220066585dd /sys-fs
parentmedia-sound/rhythmbox: bump to 3.4 (diff)
downloadgentoo-ac76c26fe0e368fc820a3aef4c8603becdda47c1.tar.gz
gentoo-ac76c26fe0e368fc820a3aef4c8603becdda47c1.tar.bz2
gentoo-ac76c26fe0e368fc820a3aef4c8603becdda47c1.zip
sys-fs/btfs: initial import
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/btfs/Manifest1
-rw-r--r--sys-fs/btfs/btfs-2.11.ebuild37
-rw-r--r--sys-fs/btfs/metadata.xml11
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-fs/btfs/Manifest b/sys-fs/btfs/Manifest
new file mode 100644
index 000000000000..09f67ef2abaf
--- /dev/null
+++ b/sys-fs/btfs/Manifest
@@ -0,0 +1 @@
+DIST btfs-2.11.tar.gz 21636 SHA256 7c15001e6206c5c28350df0e1609ab10cd7e1578908f46eb334d3b41634a8ba8 SHA512 3b185139692525b59fb3981bcd1a9645fedb3a7acf8709fd0d4c4233b1598cc247263f8935801ed448c358e2c7aba1cc845725f8ec07d3498cd4f81d0d4e6ab0 WHIRLPOOL 03ed85a4858fef2f87eb5c873bb2b5ebb3ec34657239b96481e7c9b20c7cb361988431b1af0a1df1ad2fc92cfb41bfd113dc96b6d7a57e03b52d292fbf7e6215
diff --git a/sys-fs/btfs/btfs-2.11.ebuild b/sys-fs/btfs/btfs-2.11.ebuild
new file mode 100644
index 000000000000..c87bad1961b2
--- /dev/null
+++ b/sys-fs/btfs/btfs-2.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit autotools python-r1
+
+DESCRIPTION="a bittorrent filesystem based on FUSE"
+HOMEPAGE="https://github.com/johang/btfs"
+SRC_URI="https://github.com/johang/btfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=sys-fs/fuse-2.8.0
+ >=net-misc/curl-7.22.0
+ dev-libs/boost:=
+ >=net-libs/rb_libtorrent-0.16.0"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # don't install btplay via make
+ sed -i '/^SUBDIRS =/s/scripts//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript scripts/btplay
+}
diff --git a/sys-fs/btfs/metadata.xml b/sys-fs/btfs/metadata.xml
new file mode 100644
index 000000000000..21630ede97af
--- /dev/null
+++ b/sys-fs/btfs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">johang/btfs</remote-id>
+ </upstream>
+</pkgmetadata>