summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/py3status
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/py3status')
-rw-r--r--x11-misc/py3status/Manifest1
-rw-r--r--x11-misc/py3status/metadata.xml14
-rw-r--r--x11-misc/py3status/py3status-2.4.ebuild27
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/py3status/Manifest b/x11-misc/py3status/Manifest
new file mode 100644
index 000000000000..fb2f550b171a
--- /dev/null
+++ b/x11-misc/py3status/Manifest
@@ -0,0 +1 @@
+DIST py3status-2.4.tar.gz 47991 SHA256 35021e5d9085f6d99de0e406d961cf0f79415ed9eb933181b3cf08b3ebec6826 SHA512 e2ff8b438e327f494daa94be283907049cd12722aef1a96300bbc21124a11b2c072a893aa7945584bc4bed84e27cc09bba7f17065e65265bcaaa2f3af3b3c944 WHIRLPOOL 35978385988e24ccbf62b3b1b167d21bbfbdbe4e6c481980a6fb583e8ef5336105fac2fa321fac832d19c3ada83aa40e3aa865e8701b3c8998c0fd3a569cc047
diff --git a/x11-misc/py3status/metadata.xml b/x11-misc/py3status/metadata.xml
new file mode 100644
index 000000000000..0387375d488f
--- /dev/null
+++ b/x11-misc/py3status/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ultrabug@gentoo.org</email>
+ <name>Alexys Jacob</name>
+ </maintainer>
+ <longdescription lang="en">py3status is an extensible
+ i3status wrapper written in python</longdescription>
+ <upstream>
+ <remote-id type="pypi">py3status</remote-id>
+ <remote-id type="github">ultrabug/py3status</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/py3status/py3status-2.4.ebuild b/x11-misc/py3status/py3status-2.4.ebuild
new file mode 100644
index 000000000000..ffe53b43ed31
--- /dev/null
+++ b/x11-misc/py3status/py3status-2.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SRC_URI="https://github.com/ultrabug/py3status/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+inherit distutils-r1
+
+MY_PN="py3status"
+MY_P="${MY_PN}-${PV/_/-}"
+
+DESCRIPTION="py3status is an extensible i3status wrapper written in python"
+HOMEPAGE="https://github.com/ultrabug/py3status"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/i3status"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}