summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/mepl/files/gcc433.patch4
-rw-r--r--app-misc/mepl/mepl-0.45-r1.ebuild30
2 files changed, 32 insertions, 2 deletions
diff --git a/app-misc/mepl/files/gcc433.patch b/app-misc/mepl/files/gcc433.patch
index 821f1330e377..0fd857a9ae30 100644
--- a/app-misc/mepl/files/gcc433.patch
+++ b/app-misc/mepl/files/gcc433.patch
@@ -1,5 +1,5 @@
---- mepl.c 2009-04-07 21:17:32.000000000 +0200
-+++ mepl.c.new 2009-04-07 21:16:48.000000000 +0200
+--- a/mepl.c 2009-04-07 21:17:32.000000000 +0200
++++ b/mepl.c 2009-04-07 21:16:48.000000000 +0200
@@ -1,3 +1,4 @@
+#include <stdlib.h>
#define VERSION "0.45 Don Nov 25 19:13:58 CET 1999"
diff --git a/app-misc/mepl/mepl-0.45-r1.ebuild b/app-misc/mepl/mepl-0.45-r1.ebuild
new file mode 100644
index 000000000000..aa2c0ede0822
--- /dev/null
+++ b/app-misc/mepl/mepl-0.45-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Self-employed-mode software for 3COM/USR message modems"
+HOMEPAGE="http://www.hof-berlin.de/mepl/"
+SRC_URI="http://www.hof-berlin.de/mepl/mepl${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${PN}${PV}"
+
+PATCHES=( "${FILESDIR}/gcc433.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DMEPLCONFIG=\\\"/etc/mepl.conf\\\" ${LDFLAGS}" en
+}
+
+src_install() {
+ dobin "${PN}" "${PN}mail"
+ insinto /etc
+ doins "${PN}.conf"
+ newman "${PN}.en" "${PN}.7"
+}