summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-46.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 5cb380de14e3..5bf5519916d7 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1 +1,2 @@
DIST orca-45.2.tar.xz 3997024 BLAKE2B dfdf113694127323a92450b04b20fcc5655be0236c0173167d5d15478703b676c3fd8c1de0e75783875c5d2d40541c764fb002314d66c7570475cd63f6bfa473 SHA512 57eee451cf0da52e1297beae6c6d527886721b23c3415a5e046f3431876fdf1603dbd81ca763ed614ace68e7db96d90b413c663f113d0033ec1f2797df7bf589
+DIST orca-46.2.tar.xz 3431952 BLAKE2B 56b8c31318ecfaf6acda365192e0dd70feb835e449ebe1e0c0292a2230c44659ddc4e9cf1fa87aba1694e3ba2c8c695754901c4a797720979af3a8143f0b0b00 SHA512 e55d5dba18b70ac2b70809f9e0af82e1fad8c72d9f3a7e03c6e4c1da29e133f80b3dabf9ad007873587b4b01a4ff36947e4ea38d7afd60748f8f98219a6a24e0
diff --git a/app-accessibility/orca/orca-46.2.ebuild b/app-accessibility/orca/orca-46.2.ebuild
new file mode 100644
index 000000000000..abe505aaa1bf
--- /dev/null
+++ b/app-accessibility/orca/orca-46.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.50:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.46[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ local emesonargs=(
+ -Dspiel=false # spiel not yet in gentoo
+ )
+ meson_src_configure
+}
+
+src_install() {
+ default
+ python_optimize
+}