summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/snapd')
-rw-r--r--app-containers/snapd/snapd-2.54.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-containers/snapd/snapd-2.54.3.ebuild b/app-containers/snapd/snapd-2.54.3.ebuild
index 6366a2d391fc..bf6b2a0a243e 100644
--- a/app-containers/snapd/snapd-2.54.3.ebuild
+++ b/app-containers/snapd/snapd-2.54.3.ebuild
@@ -4,7 +4,7 @@
EAPI=7
EGO_PN="github.com/snapcore/${PN}"
-inherit autotools bash-completion-r1 golang-vcs-snapshot linux-info readme.gentoo-r1 systemd xdg-utils
+inherit autotools bash-completion-r1 flag-o-matic golang-vcs-snapshot linux-info readme.gentoo-r1 systemd xdg-utils
DESCRIPTION="Service and tools for management of snap packages"
HOMEPAGE="http://snapcraft.io/"
@@ -61,6 +61,9 @@ pkg_setup() {
CONFIG_CHECK+=" ~SECURITY_APPARMOR"
fi
linux-info_pkg_setup
+
+ # Seems to have issues building with -O3, switch to -O2
+ replace-flags -O3 -O2
}
src_prepare() {