summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/libreoffice-6.1.1.2.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-6.1.9999.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/app-office/libreoffice/libreoffice-6.1.1.2.ebuild b/app-office/libreoffice/libreoffice-6.1.1.2.ebuild
index 6105cb607ab1..285959c3464f 100644
--- a/app-office/libreoffice/libreoffice-6.1.1.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.1.1.2.ebuild
@@ -63,8 +63,8 @@ unset ADDONS_SRC
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
-IUSE="bluetooth +branding coinmp +cups dbus debug eds firebird googledrive
-gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
+IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
+googledrive gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -144,6 +144,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
+ accessibility? ( dev-python/lxml[${PYTHON_USEDEP}] )
bluetooth? ( net-wireless/bluez )
coinmp? ( sci-libs/coinor-mp )
cups? ( net-print/cups )
@@ -439,6 +440,7 @@ src_configure() {
$(use_enable pdfimport)
$(use_enable postgres postgresql-sdbc)
$(use_enable vlc)
+ $(use_with accessibility lxml)
$(use_with coinmp system-coinmp)
$(use_with googledrive gdrive-client-id ${google_default_client_id})
$(use_with googledrive gdrive-client-secret ${google_default_client_secret})
diff --git a/app-office/libreoffice/libreoffice-6.1.9999.ebuild b/app-office/libreoffice/libreoffice-6.1.9999.ebuild
index 01637fc6d612..e6352a55b2d1 100644
--- a/app-office/libreoffice/libreoffice-6.1.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.1.9999.ebuild
@@ -63,8 +63,8 @@ unset ADDONS_SRC
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
-IUSE="bluetooth +branding coinmp +cups dbus debug eds firebird googledrive
-gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
+IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
+googledrive gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -144,6 +144,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
+ accessibility? ( dev-python/lxml[${PYTHON_USEDEP}] )
bluetooth? ( net-wireless/bluez )
coinmp? ( sci-libs/coinor-mp )
cups? ( net-print/cups )
@@ -439,6 +440,7 @@ src_configure() {
$(use_enable pdfimport)
$(use_enable postgres postgresql-sdbc)
$(use_enable vlc)
+ $(use_with accessibility lxml)
$(use_with coinmp system-coinmp)
$(use_with googledrive gdrive-client-id ${google_default_client_id})
$(use_with googledrive gdrive-client-secret ${google_default_client_secret})
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 95989401be93..54d654db3d59 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -63,8 +63,8 @@ unset ADDONS_SRC
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
-IUSE="bluetooth +branding coinmp +cups dbus debug eds firebird googledrive
-gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
+IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
+googledrive gstreamer +gtk gtk2 kde mysql odk pdfimport postgres test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -144,6 +144,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
+ accessibility? ( dev-python/lxml[${PYTHON_USEDEP}] )
bluetooth? (
dev-libs/glib:2
net-wireless/bluez
@@ -441,6 +442,7 @@ src_configure() {
$(use_enable pdfimport)
$(use_enable postgres postgresql-sdbc)
$(use_enable vlc)
+ $(use_with accessibility lxml)
$(use_with coinmp system-coinmp)
$(use_with googledrive gdrive-client-id ${google_default_client_id})
$(use_with googledrive gdrive-client-secret ${google_default_client_secret})