summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild10
-rw-r--r--dev-ml/camlp4/camlp4-4.09_p1-r1.ebuild6
-rw-r--r--dev-ml/camlp4/camlp4-4.10_p1-r2.ebuild6
-rw-r--r--dev-ml/camlp4/camlp4-4.11_p1-r2.ebuild4
-rw-r--r--dev-ml/camlp4/camlp4-4.12-r1.ebuild4
-rw-r--r--dev-ml/camlp4/camlp4-4.13-r1.ebuild4
6 files changed, 21 insertions, 13 deletions
diff --git a/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild b/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
index 7c3455031b75..fbeee42c3a43 100644
--- a/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.05_p1-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PV=${PV/_p/+}
MY_P=${PN}-${MY_PV}
+
DESCRIPTION="System for writing extensible parsers for programming languages"
HOMEPAGE="https://github.com/camlp4/camlp4"
SRC_URI="https://github.com/camlp4/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P/_p/-}"
LICENSE="LGPL-2-with-linking-exception"
SLOT="0/${PV}"
@@ -17,9 +17,13 @@ IUSE="+ocamlopt"
RDEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
DEPEND="${RDEPEND}
- dev-ml/ocamlbuild
+ dev-ml/ocamlbuild[ocamlopt?]
dev-ml/findlib:="
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/${P/_p/-}"
+
src_configure() {
./configure \
--bindir="${EPREFIX}/usr/bin" \
diff --git a/dev-ml/camlp4/camlp4-4.09_p1-r1.ebuild b/dev-ml/camlp4/camlp4-4.09_p1-r1.ebuild
index 4df4e6606fe2..45915fd4cf46 100644
--- a/dev-ml/camlp4/camlp4-4.09_p1-r1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.09_p1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,9 +17,11 @@ IUSE="+ocamlopt"
RDEPEND="dev-lang/ocaml:0/4.09[ocamlopt?]"
DEPEND="${RDEPEND}
- dev-ml/ocamlbuild
+ dev-ml/ocamlbuild[ocamlopt?]
dev-ml/findlib:="
+QA_FLAGS_IGNORED='.*'
+
S=${WORKDIR}/${P/_p/-}
PATCHES=( "${FILESDIR}/reload.patch" )
diff --git a/dev-ml/camlp4/camlp4-4.10_p1-r2.ebuild b/dev-ml/camlp4/camlp4-4.10_p1-r2.ebuild
index 539fe3cd8554..06d603572592 100644
--- a/dev-ml/camlp4/camlp4-4.10_p1-r2.ebuild
+++ b/dev-ml/camlp4/camlp4-4.10_p1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,9 +17,11 @@ IUSE="+ocamlopt"
RDEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
DEPEND="${RDEPEND}
- dev-ml/ocamlbuild
+ dev-ml/ocamlbuild[ocamlopt?]
dev-ml/findlib:="
+QA_FLAGS_IGNORED='.*'
+
S=${WORKDIR}/${P/_p/-}
PATCHES=( "${FILESDIR}/reload.patch" )
diff --git a/dev-ml/camlp4/camlp4-4.11_p1-r2.ebuild b/dev-ml/camlp4/camlp4-4.11_p1-r2.ebuild
index 24d6b91a79bb..f3e7028826d7 100644
--- a/dev-ml/camlp4/camlp4-4.11_p1-r2.ebuild
+++ b/dev-ml/camlp4/camlp4-4.11_p1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ IUSE="+ocamlopt"
RDEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
DEPEND="${RDEPEND}
- dev-ml/ocamlbuild
+ dev-ml/ocamlbuild[ocamlopt?]
dev-ml/findlib:="
QA_FLAGS_IGNORED='.*'
diff --git a/dev-ml/camlp4/camlp4-4.12-r1.ebuild b/dev-ml/camlp4/camlp4-4.12-r1.ebuild
index e159ddff977f..06d603572592 100644
--- a/dev-ml/camlp4/camlp4-4.12-r1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ IUSE="+ocamlopt"
RDEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
DEPEND="${RDEPEND}
- dev-ml/ocamlbuild
+ dev-ml/ocamlbuild[ocamlopt?]
dev-ml/findlib:="
QA_FLAGS_IGNORED='.*'
diff --git a/dev-ml/camlp4/camlp4-4.13-r1.ebuild b/dev-ml/camlp4/camlp4-4.13-r1.ebuild
index e159ddff977f..06d603572592 100644
--- a/dev-ml/camlp4/camlp4-4.13-r1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.13-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ IUSE="+ocamlopt"
RDEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
DEPEND="${RDEPEND}
- dev-ml/ocamlbuild
+ dev-ml/ocamlbuild[ocamlopt?]
dev-ml/findlib:="
QA_FLAGS_IGNORED='.*'