summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cffi')
-rw-r--r--dev-python/cffi/cffi-1.11.5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/cffi/cffi-1.11.5.ebuild b/dev-python/cffi/cffi-1.11.5.ebuild
index 9cd44285b9ce..20a17f5c3fcf 100644
--- a/dev-python/cffi/cffi-1.11.5.ebuild
+++ b/dev-python/cffi/cffi-1.11.5.ebuild
@@ -7,7 +7,7 @@ EAPI=6
# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-inherit distutils-r1
+inherit distutils-r1 toolchain-funcs
DESCRIPTION="Foreign Function Interface for Python calling C code"
HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
@@ -29,6 +29,10 @@ DEPEND="${RDEPEND}
# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
DISTUTILS_IN_SOURCE_BUILD=1
+src_configure() {
+ tc-export PKG_CONFIG
+}
+
python_compile_all() {
use doc && emake -C doc html
}