summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/chameleon/chameleon-2.19.ebuild')
-rw-r--r--dev-python/chameleon/chameleon-2.19.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/chameleon/chameleon-2.19.ebuild b/dev-python/chameleon/chameleon-2.19.ebuild
deleted file mode 100644
index 1a62d915da39..000000000000
--- a/dev-python/chameleon/chameleon-2.19.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_PN="Chameleon"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Fast HTML/XML template compiler for Python"
-HOMEPAGE="http://chameleon.repoze.org https://pypi.python.org/pypi/Chameleon"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="repoze"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( _build/html/{[a-z]*,_static} )
-
- distutils-r1_python_install_all
-}