summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mechanize/mechanize-0.4.6.ebuild')
-rw-r--r--dev-python/mechanize/mechanize-0.4.6.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/mechanize/mechanize-0.4.6.ebuild b/dev-python/mechanize/mechanize-0.4.6.ebuild
deleted file mode 100644
index 0dbed48e2d13..000000000000
--- a/dev-python/mechanize/mechanize-0.4.6.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="https://github.com/python-mechanize/mechanize"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- ${RDEPEND}
- )
-"
-
-python_test() {
- "${EPYTHON}" run_tests.py || die
-}