summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numba')
-rw-r--r--dev-python/numba/Manifest2
-rw-r--r--dev-python/numba/files/numba-skip-tests.patch14
-rw-r--r--dev-python/numba/metadata.xml17
-rw-r--r--dev-python/numba/numba-0.37.0.ebuild45
-rw-r--r--dev-python/numba/numba-0.39.0.ebuild45
5 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/numba/Manifest b/dev-python/numba/Manifest
deleted file mode 100644
index 6cc4b9cbb0cd..000000000000
--- a/dev-python/numba/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST numba-0.37.0.tar.gz 1734667 BLAKE2B 20fd765d226e6e71a0e94bbf8c6a605ef7b4cf8ba6e39667001051c642fb9b872540482e710e020c0fca6653d9ca4518ce82e48681613f28ac5b9e2346bece4f SHA512 83a4e5a28a43ed1cd6584ccd63aac38a928af48c424ed119bc86487f0a2bfb9875c34f6fe0a03446d8c8e9179be81f831200c12ff31edc22bc4741789095f861
-DIST numba-0.39.0.tar.gz 1782489 BLAKE2B 77a6afe587ce3ae0ccd782e329e626d63ab58b84a2aeb836710fc0c13dcc88e16ab36e7426c6d9ff88c6d5be854915128dc2868d7fa71511ec9c8eea9debffe7 SHA512 f9cabf39fea543495425ba326aad34a52d317ebef61e5b298588764214bb396ea43871d32875f0882a36909bb12fc2e3807c38b5fc60ff5d9e6dc9ccdd36bf6e
diff --git a/dev-python/numba/files/numba-skip-tests.patch b/dev-python/numba/files/numba-skip-tests.patch
deleted file mode 100644
index 2c177c07034c..000000000000
--- a/dev-python/numba/files/numba-skip-tests.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/659804
-
-diff --git a/numba/tests/test_linalg.py b/numba/tests/test_linalg.py
-index 46bff63e8..53056ab23 100644
---- a/numba/tests/test_linalg.py
-+++ b/numba/tests/test_linalg.py
-@@ -1282,6 +1282,7 @@ class TestLinalgLstsq(TestLinalgSystems):
- # Suggestions for improvements are welcomed!
-
- @needs_lapack
-+ @unittest.skipIf(sys.maxsize < 2 ** 31, "errors with 32-bit address space")
- def test_linalg_lstsq(self):
- """
- Test np.linalg.lstsq
diff --git a/dev-python/numba/metadata.xml b/dev-python/numba/metadata.xml
deleted file mode 100644
index f9cb6d121825..000000000000
--- a/dev-python/numba/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!--maintainer-needed-->
- <longdescription lang="en">
- Numba is a NumPy-aware optimizing compiler for Python. It uses the LLVM
- compiler infrastructure to compile Python syntax to machine code.
- It is aware of NumPy arrays as typed memory regions and so can
- speed-up code using NumPy arrays. Other, less well-typed code will be
- translated to Python C-API calls effectively removing the
- "interpreter" but not removing the dynamic indirection.
-</longdescription>
- <upstream>
- <remote-id type="pypi">numba</remote-id>
- <remote-id type="github">numba/numba</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/numba/numba-0.37.0.ebuild b/dev-python/numba/numba-0.37.0.ebuild
deleted file mode 100644
index c7708590b698..000000000000
--- a/dev-python/numba/numba-0.37.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
-HOMEPAGE="http://numba.pydata.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/llvmlite-0.22.0[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-PATCHES=(
- "${FILESDIR}"/numba-skip-tests.patch
-)
-
-python_test() {
- cd "${BUILD_DIR}/lib" || die
- ${EPYTHON} -m numba.runtests -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/numba/numba-0.39.0.ebuild b/dev-python/numba/numba-0.39.0.ebuild
deleted file mode 100644
index 50196a853e65..000000000000
--- a/dev-python/numba/numba-0.39.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
-HOMEPAGE="http://numba.pydata.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/llvmlite-0.22.0[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-PATCHES=(
- "${FILESDIR}"/numba-skip-tests.patch
-)
-
-python_test() {
- cd "${BUILD_DIR}/lib" || die
- ${EPYTHON} -m numba.runtests -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}