summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyclipper')
-rw-r--r--dev-python/pyclipper/Manifest1
-rw-r--r--dev-python/pyclipper/pyclipper-1.3.0_p2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyclipper/Manifest b/dev-python/pyclipper/Manifest
index 6c0a5687884b..b610642b41d5 100644
--- a/dev-python/pyclipper/Manifest
+++ b/dev-python/pyclipper/Manifest
@@ -1 +1,2 @@
DIST pyclipper-1.3.0.tar.gz 51405 BLAKE2B a7a3e81452c8178d907528b7595fb92521dfb039a6ea116d7f189639ea2975d8058ac1f685a211c98be921c41a694d89f7f431264dfe366e3acc842b25d670f4 SHA512 bee6c5f835e84baa65cbca1d812219bd94272010bbeed365b3835ef3d191042129fdcccdd85ce7841f60f46cbfd52edd270d108ff81d64b0ca712c1369394d40
+DIST pyclipper-1.3.0_p2.tar.gz 51079 BLAKE2B e5af84c15a19bf2ac7f0df78d588d34451c6f0a0bc40fa6a28dd8ef5f697e1d62eb4e14ac184e325ce4d6ad1aab23254d6e91857e3a44636a1652f86aa1778e9 SHA512 08b7f8443b0e98ddf7230824a451b0b0023402c4cecb44c1a264e08d204a3da455aef742b2ffcc0acf44a4ec3b864302af0d7a7ec34bb6a2080340b2320797dd
diff --git a/dev-python/pyclipper/pyclipper-1.3.0_p2.ebuild b/dev-python/pyclipper/pyclipper-1.3.0_p2.ebuild
new file mode 100644
index 000000000000..1437117d8d88
--- /dev/null
+++ b/dev-python/pyclipper/pyclipper-1.3.0_p2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
+}