summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/curb')
-rw-r--r--dev-ruby/curb/Manifest1
-rw-r--r--dev-ruby/curb/curb-1.0.5.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-ruby/curb/Manifest b/dev-ruby/curb/Manifest
index ecb4fca25af8..031f82eb57a0 100644
--- a/dev-ruby/curb/Manifest
+++ b/dev-ruby/curb/Manifest
@@ -1,2 +1 @@
-DIST curb-1.0.5.gem 92160 BLAKE2B 395cdbb3255d5a38dfd472787785738dfff8ec7eed69e7b93ae2d993c90635d427a6275cd3510b406fccc7b999bdedf544cb4177132cc890f0473452ad1984c9 SHA512 0b90da7757ee37bd542e2ab31407235788f103e67c987fd820073eb70ecae7cea55cc5ecdc354145ead58cb9762db0f8f27416301fbca93bc0f7a7966a5d8a63
DIST curb-1.0.6.gem 92160 BLAKE2B b764611321981e1b5706c51400c3b08f1bd9a73ee1df56f3fa818ac0d7074be6e7b77969794cd1452f2d6f5685f29e772383913276cb4c81576760057f278584 SHA512 24c0e65a88bda3dd20a4d9386be22a6f09aa9a86f37c0f462048e621e95567bb3f825e41c41889a1699a966a6943ce1ce9c380287ecb120eef7e268f598a2de7
diff --git a/dev-ruby/curb/curb-1.0.5.ebuild b/dev-ruby/curb/curb-1.0.5.ebuild
deleted file mode 100644
index 87a4cb375d1a..000000000000
--- a/dev-ruby/curb/curb-1.0.5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-
-DEPEND+=" net-misc/curl[ssl] test? ( net-misc/curl )"
-RDEPEND+=" net-misc/curl[ssl]"
-
-ruby_add_bdepend "test? ( dev-ruby/webrick )"
-
-all_ruby_prepare() {
- # fix tests when localhost is also ::1
- sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
- # avoid tests making outside network connections
- rm tests/bug_postfields_crash.rb || die
- sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
- -i tests/tc_curl_easy.rb || die
- sed -e '/test_connection_keepalive/aomit "network connection needed"' \
- -i tests/tc_curl_multi.rb || die
-
- # Fix test that expects wrong output
- sed -i -e 's/200 OK /200 OK/' tests/tc_curl_easy.rb || die
-
- # avoid failing tests where failure condition seems weird, no
- # upstream travis so not clear if the test is indeed broken.
- sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
-
- # avoid test requiring ntlm support on curl which is no longer available in gentoo
- sed -i -e '/test_username_password/aomit "ntlm support in curl needed"' -i tests/tc_curl_easy.rb || die
-
- # Skip tests with currently unpackaged ruby_memcheck
- sed -i -e '/ruby_memcheck/ s:^:#: ; /RubyMemcheck/,/^end/ s:^:#:' Rakefile
-}