summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/uglifier/uglifier-3.0.1.ebuild')
-rw-r--r--dev-ruby/uglifier/uglifier-3.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/uglifier/uglifier-3.0.1.ebuild b/dev-ruby/uglifier/uglifier-3.0.1.ebuild
new file mode 100644
index 000000000000..f77f680fef04
--- /dev/null
+++ b/dev-ruby/uglifier/uglifier-3.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby wrapper for UglifyJS JavaScript compressor"
+HOMEPAGE="https://github.com/lautis/uglifier"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~amd64-linux"
+
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/execjs-0.3.0:*"
+
+ruby_add_bdepend "test? ( dev-ruby/sourcemap )"