summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild5
-rw-r--r--media-libs/mesa/metadata.xml1
2 files changed, 5 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 720e8a4c73f5..0d4b0abb567f 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -38,7 +38,7 @@ done
IUSE="${IUSE_VIDEO_CARDS}
+classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +libglvnd +llvm
lm_sensors opencl osmesa pax_kernel pic selinux test unwind vaapi valgrind
- vdpau vulkan wayland xa xvmc"
+ vdpau vulkan vulkan-overlay wayland xa xvmc"
REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
@@ -47,6 +47,7 @@ REQUIRED_USE="
vulkan? ( dri3
|| ( video_cards_i965 video_cards_radeonsi )
video_cards_radeonsi? ( llvm ) )
+ vulkan-overlay? ( vulkan )
wayland? ( egl gbm )
video_cards_freedreno? ( gallium )
video_cards_intel? ( classic )
@@ -216,6 +217,7 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
valgrind? ( dev-util/valgrind )
+ vulkan-overlay? ( media-libs/vulkan-layers[${MULTILIB_USEDEP}] )
x11-base/xorg-proto
x11-libs/libXrandr[${MULTILIB_USEDEP}]
$(python_gen_any_dep ">=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]")
@@ -472,6 +474,7 @@ multilib_src_configure() {
-Ddri-drivers=$(driver_list "${DRI_DRIVERS[*]}")
-Dgallium-drivers=$(driver_list "${GALLIUM_DRIVERS[*]}")
-Dvulkan-drivers=$(driver_list "${VULKAN_DRIVERS[*]}")
+ $(meson_use vulkan-overlay vulkan-overlay-layer)
--buildtype $(usex debug debug plain)
-Db_ndebug=$(usex debug false true)
)
diff --git a/media-libs/mesa/metadata.xml b/media-libs/mesa/metadata.xml
index 23679a78209d..8099392fa046 100644
--- a/media-libs/mesa/metadata.xml
+++ b/media-libs/mesa/metadata.xml
@@ -24,6 +24,7 @@
<flag name="valgrind">Compile in valgrind memory hints</flag>
<flag name="vdpau">Enable the VDPAU acceleration interface for the Gallium3D Video Layer.</flag>
<flag name="vulkan">Enable Vulkan drivers</flag>
+ <flag name="vulkan-overlay">Enable vulkan-overlay-layer for vulkan stats"</flag>
<flag name="wayland">Enable support for dev-libs/wayland</flag>
<flag name="xa">Enable the XA (X Acceleration) API for Gallium3D.</flag>
<flag name="xvmc">Enable the XvMC acceleration interface for the Gallium3D Video Layer.</flag>