summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/x11-ssh-askpass')
-rw-r--r--net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
index a799f42b4c5e..155003835707 100644
--- a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
+++ b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,13 +21,14 @@ RDEPEND="virtual/ssh
x11-libs/libXt"
DEPEND="${RDEPEND}"
BDEPEND="app-text/rman
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
src_configure() {
econf --libexecdir=/usr/"$(get_libdir)"/misc \
--disable-installing-app-defaults
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die "xmkmf failed"
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die "xmkmf failed"
}
src_compile() {