summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/encfs/encfs-1.9.5-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/sys-fs/encfs/encfs-1.9.5-r1.ebuild b/sys-fs/encfs/encfs-1.9.5-r1.ebuild
deleted file mode 100644
index 3d07c9a58501..000000000000
--- a/sys-fs/encfs/encfs-1.9.5-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake
-
-DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
-HOMEPAGE="https://vgough.github.io/encfs/"
-SRC_URI="https://github.com/vgough/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm ~ppc64 ~sparc x86"
-IUSE="nls"
-
-RDEPEND="
- dev-libs/openssl:0=
- dev-libs/tinyxml2:0=
- sys-fs/fuse:0=
- sys-libs/zlib"
-DEPEND="
- ${RDEPEND}
- dev-lang/perl
- sys-devel/gettext
- virtual/pkgconfig"
-
-# Build dir is hardcoded in test suite, but we restrict them
-# because they can lead to false negatives, bug #630486
-RESTRICT="test"
-BUILD_DIR="${S}/build"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_NLS="$(usex nls)"
- -DUSE_INTERNAL_TINYXML=OFF
- -DBUILD_UNIT_TESTS=OFF
- -DBUILD_SHARED_LIBS=OFF
- )
- cmake_src_configure
-}