summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/at')
-rw-r--r--sys-process/at/Manifest2
-rw-r--r--sys-process/at/at-3.1.14.ebuild82
-rw-r--r--sys-process/at/at-3.1.16-r1.ebuild82
-rw-r--r--sys-process/at/at-3.1.16.ebuild82
-rw-r--r--sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch12
-rw-r--r--sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch22
-rw-r--r--sys-process/at/files/at-3.1.13-getloadavg.patch19
-rw-r--r--sys-process/at/files/at-3.1.13-parallel-make-fix.patch11
-rw-r--r--sys-process/at/files/at-3.1.14-Makefile.patch18
-rw-r--r--sys-process/at/files/at-3.1.8-more-deny.patch20
-rw-r--r--sys-process/at/files/at.pamd-3.1.13-r19
-rw-r--r--sys-process/at/files/atd.confd8
-rwxr-xr-xsys-process/at/files/atd.rc713
-rwxr-xr-xsys-process/at/files/atd.rc814
-rw-r--r--sys-process/at/files/atd.service13
-rw-r--r--sys-process/at/metadata.xml9
16 files changed, 416 insertions, 0 deletions
diff --git a/sys-process/at/Manifest b/sys-process/at/Manifest
new file mode 100644
index 000000000000..9414db555d7d
--- /dev/null
+++ b/sys-process/at/Manifest
@@ -0,0 +1,2 @@
+DIST at_3.1.14.orig.tar.gz 122865 SHA256 cd092bf05d29c25b286f55a960ce8b8c3c5beb571d86ed8eb1dfb3b61291b3ae SHA512 06c0e66062a4e96a4a86c7a01d4ec93d47a1a40f7bc0649b3ddb1775b47a2d32d5e6ec9f9f4bdd044ed72e8c327f85128b19f7dc5e467d406d2d106a6952f7b2 WHIRLPOOL 3c6ca09e46531a12eda7f99710cf461f6831c3a1fd48d67b24e631362149b760b4906852b3bd5f6c03cfae6ce0f21eb5bd386ec7f8e3e1ea1cf3d960577a6036
+DIST at_3.1.16.orig.tar.gz 123174 SHA256 cb9af59c6a54edce9536ba629841055409d1f89d8ae26494727a97141fb4d5c1 SHA512 d63132536d01153c4b38499b316c8a7980cd47a75b00fb5edc6e41f24345f97b55b20e5801d50f1bde2f337acc7bdb7e318456c241415e7b7bddee7e51e68ad5 WHIRLPOOL 7ad8a15e53afc915d0cf52b1b42d810876538317665e05232a3b898244558cdb76cad727e2479db3437249e3e63dab2c824c30bb94bd28e6f65edbd5848d2e2c
diff --git a/sys-process/at/at-3.1.14.ebuild b/sys-process/at/at-3.1.14.ebuild
new file mode 100644
index 000000000000..1aafee53b70f
--- /dev/null
+++ b/sys-process/at/at-3.1.14.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic pam user systemd
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="pam selinux"
+
+DEPEND="virtual/mta
+ >=sys-devel/autoconf-2.64
+ sys-devel/bison
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ epatch "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
+
+ eautoconf
+}
+
+src_configure() {
+ use pam || my_conf="--without-pam"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf}
+}
+
+src_install() {
+ emake install IROOT="${D}"
+
+ newinitd "${FILESDIR}"/atd.rc7 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ chown at:at "${ROOT}/var/spool/at/atjobs"
+ chmod 1770 "${ROOT}/var/spool/at/atjobs"
+ chown at:at "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chmod 0600 "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chown at:at "${ROOT}/var/spool/at/atspool"
+ chmod 1770 "${ROOT}/var/spool/at/atspool"
+}
diff --git a/sys-process/at/at-3.1.16-r1.ebuild b/sys-process/at/at-3.1.16-r1.ebuild
new file mode 100644
index 000000000000..0f7bed4d0e20
--- /dev/null
+++ b/sys-process/at/at-3.1.16-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic pam user systemd
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam selinux"
+
+DEPEND="virtual/mta
+ >=sys-devel/autoconf-2.64
+ sys-devel/bison
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ epatch "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
+
+ eautoconf
+}
+
+src_configure() {
+ use pam || my_conf="--without-pam"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf}
+}
+
+src_install() {
+ emake install IROOT="${D}"
+
+ newinitd "${FILESDIR}"/atd.rc8 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ chown at:at "${ROOT}/var/spool/at/atjobs"
+ chmod 1770 "${ROOT}/var/spool/at/atjobs"
+ chown at:at "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chmod 0600 "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chown at:at "${ROOT}/var/spool/at/atspool"
+ chmod 1770 "${ROOT}/var/spool/at/atspool"
+}
diff --git a/sys-process/at/at-3.1.16.ebuild b/sys-process/at/at-3.1.16.ebuild
new file mode 100644
index 000000000000..55b2506c423d
--- /dev/null
+++ b/sys-process/at/at-3.1.16.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic pam user systemd
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="pam selinux"
+
+DEPEND="virtual/mta
+ >=sys-devel/autoconf-2.64
+ sys-devel/bison
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ epatch "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
+
+ eautoconf
+}
+
+src_configure() {
+ use pam || my_conf="--without-pam"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf}
+}
+
+src_install() {
+ emake install IROOT="${D}"
+
+ newinitd "${FILESDIR}"/atd.rc7 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ chown at:at "${ROOT}/var/spool/at/atjobs"
+ chmod 1770 "${ROOT}/var/spool/at/atjobs"
+ chown at:at "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chmod 0600 "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chown at:at "${ROOT}/var/spool/at/atspool"
+ chmod 1770 "${ROOT}/var/spool/at/atspool"
+}
diff --git a/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch b/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch
new file mode 100644
index 000000000000..8fd82e639b05
--- /dev/null
+++ b/sys-process/at/files/at-3.1.10.2-Makefile.in-parallel-make-fix.patch
@@ -0,0 +1,12 @@
+diff -Naur at-3.1.10.2.orig/Makefile.in at-3.1.10.2/Makefile.in
+--- at-3.1.10.2.orig/Makefile.in 2009-01-31 15:38:54.000000000 +0100
++++ at-3.1.10.2/Makefile.in 2009-01-31 15:39:22.000000000 +0100
+@@ -78,7 +78,7 @@
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+
+-lex.yy.c: parsetime.l
++lex.yy.c: parsetime.l y.tab.h
+ $(LEX) -i parsetime.l
+
+ atrun: atrun.in
diff --git a/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch b/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch
new file mode 100644
index 000000000000..ee24b7f13147
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-configure.in-fix-PAM-automagick-dep.patch
@@ -0,0 +1,22 @@
+--- at-3.1.13/configure.ac
++++ at-3.1.13/configure.ac
+@@ -82,10 +82,15 @@
+ AC_FUNC_VPRINTF
+ AC_FUNC_GETLOADAVG
+ AC_CHECK_FUNCS(getcwd mktime strftime setreuid setresuid sigaction waitpid)
+-AC_CHECK_HEADERS(security/pam_appl.h, [
+- PAMLIB="-lpam"
+- AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])
+-])
++AC_ARG_WITH([pam], AS_HELP_STRING([--without-pam],
++ [Build without PAM support(default: enabled)]))
++
++if test "x$with_pam" != "xno"; then
++ AC_CHECK_HEADERS(security/pam_appl.h, [
++ PAMLIB="-lpam"
++ AC_DEFINE(HAVE_PAM, 1, [Define to 1 for PAM support])
++ ])
++fi
+
+ dnl Checking for programs
+
diff --git a/sys-process/at/files/at-3.1.13-getloadavg.patch b/sys-process/at/files/at-3.1.13-getloadavg.patch
new file mode 100644
index 000000000000..7de085dcd84b
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-getloadavg.patch
@@ -0,0 +1,19 @@
+diff --git a/getloadavg.c b/getloadavg.c
+index cf5869f..c7e2b27 100644
+--- a/getloadavg.c
++++ b/getloadavg.c
+@@ -69,8 +69,12 @@ Boston, MA 02110-1301 USA */
+ #include <config.h>
+ #endif
+
+-#include "lisp.h"
+-#include "sysfile.h" /* for encapsulated open, close, read, write */
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <fcntl.h>
++
++//#include "lisp.h"
++//#include "sysfile.h" /* for encapsulated open, close, read, write */
+
+ #ifndef HAVE_GETLOADAVG
+
diff --git a/sys-process/at/files/at-3.1.13-parallel-make-fix.patch b/sys-process/at/files/at-3.1.13-parallel-make-fix.patch
new file mode 100644
index 000000000000..dec02e42310c
--- /dev/null
+++ b/sys-process/at/files/at-3.1.13-parallel-make-fix.patch
@@ -0,0 +1,11 @@
+--- at-3.1.13_orig/Makefile.in 2011-06-25 14:43:14.000000000 +0200
++++ at-3.1.13/Makefile.in 2012-03-16 17:23:26.210267660 +0100
+@@ -73,7 +73,7 @@
+ atd: $(RUNOBJECTS)
+ $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB)
+
+-y.tab.c y.tab.h: parsetime.y
++%.tab.c %.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+
+ lex.yy.c: parsetime.l
diff --git a/sys-process/at/files/at-3.1.14-Makefile.patch b/sys-process/at/files/at-3.1.14-Makefile.patch
new file mode 100644
index 000000000000..1e28619d9a82
--- /dev/null
+++ b/sys-process/at/files/at-3.1.14-Makefile.patch
@@ -0,0 +1,18 @@
+# - install into Gentoo/FHS doc dir
+
+--- at-3.1.14/Makefile.in
++++ at-3.1.14/Makefile.in
+@@ -12,8 +12,11 @@
+ man1dir = $(mandir)/man1
+ man5dir = $(mandir)/man5
+ man8dir = $(mandir)/man8
+-docdir = $(prefix)/doc
+-atdocdir = $(docdir)/at
++ifndef PF
++PF = at-$(VERSION)
++endif
++docdir = $(prefix)/share/doc
++atdocdir = $(docdir)/$(PF)
+ etcdir = @ETCDIR@
+ systemdsystemunitdir = @systemdsystemunitdir@
+
diff --git a/sys-process/at/files/at-3.1.8-more-deny.patch b/sys-process/at/files/at-3.1.8-more-deny.patch
new file mode 100644
index 000000000000..006713b97269
--- /dev/null
+++ b/sys-process/at/files/at-3.1.8-more-deny.patch
@@ -0,0 +1,20 @@
+--- at.deny
++++ at.deny
+@@ -10,6 +10,8 @@
+ lp
+ mail
+ man
++mysql
++news
+ nobody
+ operator
+ proxy
+@@ -19,6 +21,8 @@
+ qmailq
+ qmailr
+ qmails
++squid
+ sync
+ sys
++uucp
+ www-data
diff --git a/sys-process/at/files/at.pamd-3.1.13-r1 b/sys-process/at/files/at.pamd-3.1.13-r1
new file mode 100644
index 000000000000..5c529c16180e
--- /dev/null
+++ b/sys-process/at/files/at.pamd-3.1.13-r1
@@ -0,0 +1,9 @@
+#
+# The PAM configuration file for the at daemon
+#
+
+auth required pam_env.so
+auth include system-services
+account include system-services
+session include system-services
+
diff --git a/sys-process/at/files/atd.confd b/sys-process/at/files/atd.confd
new file mode 100644
index 000000000000..c2bd584dc62e
--- /dev/null
+++ b/sys-process/at/files/atd.confd
@@ -0,0 +1,8 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Define startup options for atd(8).
+# For example: ATD_OPTS="-l 3.0 -b 5"
+ATD_OPTS=""
diff --git a/sys-process/at/files/atd.rc7 b/sys-process/at/files/atd.rc7
new file mode 100755
index 000000000000..0080df718859
--- /dev/null
+++ b/sys-process/at/files/atd.rc7
@@ -0,0 +1,13 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+pidfile="/var/run/atd.pid"
+command="/usr/sbin/atd"
+command_args="${ATD_OPTS}"
+start_stop_daemon_args="--pidfile ${pidfile}"
+
+depend() {
+ need clock logger
+}
diff --git a/sys-process/at/files/atd.rc8 b/sys-process/at/files/atd.rc8
new file mode 100755
index 000000000000..1b01d9321488
--- /dev/null
+++ b/sys-process/at/files/atd.rc8
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+pidfile="/var/run/atd.pid"
+command="/usr/sbin/atd"
+command_args="${ATD_OPTS}"
+start_stop_daemon_args="--pidfile ${pidfile}"
+
+depend() {
+ need clock
+ use logger
+}
diff --git a/sys-process/at/files/atd.service b/sys-process/at/files/atd.service
new file mode 100644
index 000000000000..164fc2c0cb74
--- /dev/null
+++ b/sys-process/at/files/atd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=at (job queue) daemon
+After=networking.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/atd
+PIDFile=/run/atd.pid
+StandardOutput=syslog
+StandardError=syslog
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-process/at/metadata.xml b/sys-process/at/metadata.xml
new file mode 100644
index 000000000000..750528bcaa7c
--- /dev/null
+++ b/sys-process/at/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cron</herd>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+</pkgmetadata>