summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-60.5.2.ebuild')
-rw-r--r--www-client/firefox/firefox-60.5.2.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-60.5.2.ebuild b/www-client/firefox/firefox-60.5.2.ebuild
index ec418bbfeeef..a96c670e53ef 100644
--- a/www-client/firefox/firefox-60.5.2.ebuild
+++ b/www-client/firefox/firefox-60.5.2.ebuild
@@ -63,8 +63,6 @@ RDEPEND="
selinux? ( sec-policy/selinux-mozilla )"
DEPEND="${RDEPEND}
- >=sys-devel/llvm-4.0.1
- >=sys-devel/clang-4.0.1
amd64? ( ${ASM_DEPEND} virtual/opengl )
x86? ( ${ASM_DEPEND} virtual/opengl )"
@@ -81,7 +79,19 @@ if [[ -z $GMP_PLUGIN_LIST ]]; then
fi
llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}"
+ if ! has_version "sys-devel/clang:${LLVM_SLOT}" ; then
+ ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ return 1
+ fi
+
+ if use clang ; then
+ if ! has_version "=sys-devel/lld-${LLVM_SLOT}*" ; then
+ ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ return 1
+ fi
+ fi
+
+ einfo "Will use LLVM slot ${LLVM_SLOT}!"
}
pkg_setup() {