summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/redshift/files')
-rw-r--r--x11-misc/redshift/files/1.6-bonoboiidfix.patch43
-rw-r--r--x11-misc/redshift/files/redshift-1.7-make-conditionals.patch72
-rw-r--r--x11-misc/redshift/files/redshift-1.9-toggle.patch37
3 files changed, 0 insertions, 152 deletions
diff --git a/x11-misc/redshift/files/1.6-bonoboiidfix.patch b/x11-misc/redshift/files/1.6-bonoboiidfix.patch
deleted file mode 100644
index b4f6c4de2749..000000000000
--- a/x11-misc/redshift/files/1.6-bonoboiidfix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Description: Handle newer versions of gnome-panel gconf schema.
- In newer versions of gnome-panel (>2.30), the gconf identifier
- name for bonobo_iid was renamed to applet_iid, this caused
- redshift to be unable to locate the Clock Applet. This patch
- attempts to use the legacy behaviour, and on failure to
- retrieve the value uses the newer identifer.
-Author: Miloš Komarčević <kmilos@gmail.com>
-Bug: https://launchpad.net/bugs/706353
-Bug-Ubuntu: https://launchpad.net/bugs/706353
-Bug-Fedora: https://bugzilla.redhat.com/661145
-Bug-Gentoo: https://bugs.gentoo.org/365481
-
---- a/src/location-gnome-clock.c
-+++ b/src/location-gnome-clock.c
-@@ -104,11 +104,28 @@
- char *bonobo_iid = gconf_client_get_string(client, key,
- &error);
-
-+ /* Try both gnome-panel 2.30.x and earlier bonobo_iid key and
-+ newer applet_iid. */
- if (!error && bonobo_iid != NULL &&
- !strcmp(bonobo_iid, "OAFIID:GNOME_ClockApplet")) {
- clock_applet_count += 1;
- current_city = find_current_city(client, id);
- }
-+ else {
-+ g_free(key);
-+ key = g_strdup_printf("/apps/panel/applets/%s"
-+ "/applet_iid", id);
-+ char *applet_iid = gconf_client_get_string(client, key,
-+ &error);
-+
-+ if (!error && applet_iid != NULL &&
-+ !strcmp(applet_iid, "ClockAppletFactory::ClockApplet")) {
-+ clock_applet_count += 1;
-+ current_city = find_current_city(client, id);
-+ }
-+
-+ g_free(applet_iid);
-+ }
-
- g_free(bonobo_iid);
- g_free(key);
diff --git a/x11-misc/redshift/files/redshift-1.7-make-conditionals.patch b/x11-misc/redshift/files/redshift-1.7-make-conditionals.patch
deleted file mode 100644
index 03d150c4d80e..000000000000
--- a/x11-misc/redshift/files/redshift-1.7-make-conditionals.patch
+++ /dev/null
@@ -1,72 +0,0 @@
---- Makefile.am 2012-07-20 22:52:27.013475104 +0200
-+++ Makefile.am 2012-07-20 23:54:22.807021292 +0200
-@@ -2,43 +2,51 @@
- SUBDIRS = src po
- ACLOCAL_AMFLAGS = -I m4
-
-+_HICOLOR_FILES = \
-+ data/icons/hicolor/scalable/apps/redshift.svg \
-+ data/icons/hicolor/scalable/apps/redshift-status-on.svg \
-+ data/icons/hicolor/scalable/apps/redshift-status-off.svg
-+
-+_UBUNTU_MONO_DARK_FILES = \
-+ data/icons/ubuntu-mono-dark/scalable/apps/redshift-status-on.svg \
-+ data/icons/ubuntu-mono-dark/scalable/apps/redshift-status-off.svg
-+
-+_UBUNTU_MONO_LIGHT_FILES = \
-+ data/icons/ubuntu-mono-light/scalable/apps/redshift-status-on.svg \
-+ data/icons/ubuntu-mono-light/scalable/apps/redshift-status-off.svg
-+
-+_DESKTOP_FILES = \
-+ data/applications/gtk-redshift.desktop
-+
- # Icons
-+if ENABLE_GUI
- hicolor_icondir = @datadir@/icons/hicolor/scalable/apps
--hicolor_icon_DATA = data/icons/hicolor/scalable/apps/redshift.svg \
-- data/icons/hicolor/scalable/apps/redshift-status-on.svg \
-- data/icons/hicolor/scalable/apps/redshift-status-off.svg
-+hicolor_icon_DATA = $(_HICOLOR_FILES)
-
- if ENABLE_UBUNTU
- ubuntu_mono_dark_icondir = @datadir@/icons/ubuntu-mono-dark/scalable/apps
--ubuntu_mono_dark_icon_DATA = \
-- data/icons/ubuntu-mono-dark/scalable/apps/redshift-status-on.svg \
-- data/icons/ubuntu-mono-dark/scalable/apps/redshift-status-off.svg
-+ubuntu_mono_dark_icon_DATA = $(_UBUNTU_MONO_DARK_FILES)
-
- ubuntu_mono_light_icondir = @datadir@/icons/ubuntu-mono-light/scalable/apps
--ubuntu_mono_light_icon_DATA = \
-- data/icons/ubuntu-mono-light/scalable/apps/redshift-status-on.svg \
-- data/icons/ubuntu-mono-light/scalable/apps/redshift-status-off.svg
-+ubuntu_mono_light_icon_DATA = $(_UBUNTU_MONO_LIGHT_FILES)
-+endif
- endif
-
-
- # Desktop file
- if ENABLE_GUI
- desktopdir = @datadir@/applications
--desktop_DATA = data/applications/gtk-redshift.desktop
-+desktop_DATA = $(_DESKTOP_FILES)
- endif
-
- # man page
- dist_man1_MANS = redshift.1
-
- EXTRA_DIST = \
-- $(hicolor_icon_DATA) \
-- $(desktop_DATA)
--
--if ENABLE_UBUNTU
--EXTRA_DIST += \
-- $(ubuntu_mono_dark_icon_DATA) \
-- $(ubuntu_mono_light_icon_DATA)
--endif
-+ $(_HICOLOR_FILES) \
-+ $(_UBUNTU_MONO_DARK_FILES) \
-+ $(_UBUNTU_MONO_LIGHT_FILES) \
-+ $(_DESKTOP_FILES)
-
- # Update PO translations
- .PHONY: update-po
diff --git a/x11-misc/redshift/files/redshift-1.9-toggle.patch b/x11-misc/redshift/files/redshift-1.9-toggle.patch
deleted file mode 100644
index b28a11be2b52..000000000000
--- a/x11-misc/redshift/files/redshift-1.9-toggle.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 9426e9fba038a3b5076ed92dbe538451de8725f2 Mon Sep 17 00:00:00 2001
-From: Jon Lund Steffensen <jonlst@gmail.com>
-Date: Fri, 11 Apr 2014 00:26:57 +0200
-Subject: [PATCH] redshift-gtk: Fix crash when toggling state using the status
- icon
-
----
- src/redshift-gtk/statusicon.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/redshift-gtk/statusicon.py b/src/redshift-gtk/statusicon.py
-index 5685f08..08f28ef 100644
---- a/src/redshift-gtk/statusicon.py
-+++ b/src/redshift-gtk/statusicon.py
-@@ -79,7 +79,7 @@ def __init__(self, args=[]):
-
- # Add toggle action
- self.toggle_item = Gtk.CheckMenuItem.new_with_label(_('Enabled'))
-- self.toggle_item.connect('activate', self.toggle_cb)
-+ self.toggle_item.connect('activate', self.toggle_item_cb)
- self.status_menu.append(self.toggle_item)
-
- # Add suspend menu
-@@ -215,6 +215,10 @@ def popup_menu_cb(self, widget, button, time, data=None):
- self.status_icon, button, time)
-
- def toggle_cb(self, widget, data=None):
-+ self.remove_suspend_timer()
-+ self.child_toggle_status()
-+
-+ def toggle_item_cb(self, widget, data=None):
- # Only toggle if a change from current state was requested
- if self.is_enabled() != widget.get_active():
- self.remove_suspend_timer()
---
-1.9.1
-