summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/herbstluftwm/herbstluftwm-0.9.0.ebuild')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-0.9.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-0.9.0.ebuild b/x11-wm/herbstluftwm/herbstluftwm-0.9.0.ebuild
index a27ee0ea3e0d..c2dc9d85fed9 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-0.9.0.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-0.9.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs cmake-utils
+inherit cmake toolchain-funcs
DESCRIPTION="A manual tiling window manager for X"
HOMEPAGE="https://herbstluftwm.org/"
@@ -33,7 +33,7 @@ src_prepare() {
-e '/^install.*LICENSEDIR/d' \
-e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -41,11 +41,11 @@ src_configure() {
-DWITH_DOCUMENTATION=$(usex doc)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if ! use examples; then
rm -r "${ED}"/usr/share/doc/${PF}/examples || die