From fdeec5aa5183326e523bd708dec9c862b5b07982 Mon Sep 17 00:00:00 2001
From: orbea <orbea@riseup.net>
Date: Sat, 25 Feb 2023 10:25:07 -0800
Subject: games-emulation/prosystem-jg: Add 1.5.2 + Remove 1.5.1

Bug fix release for a buffer overflow with -D_FORTIFY_SOURCE=3 on glibc
systems.

Bug: https://bugs.gentoo.org/896382
Signed-off-by: orbea <orbea@riseup.net>
Signed-off-by: Sam James <sam@gentoo.org>
---
 games-emulation/prosystem-jg/Manifest              |  2 +-
 .../prosystem-jg/prosystem-jg-1.5.1.ebuild         | 45 ----------------------
 .../prosystem-jg/prosystem-jg-1.5.2.ebuild         | 45 ++++++++++++++++++++++
 3 files changed, 46 insertions(+), 46 deletions(-)
 delete mode 100644 games-emulation/prosystem-jg/prosystem-jg-1.5.1.ebuild
 create mode 100644 games-emulation/prosystem-jg/prosystem-jg-1.5.2.ebuild

(limited to 'games-emulation')

diff --git a/games-emulation/prosystem-jg/Manifest b/games-emulation/prosystem-jg/Manifest
index bb5f61f21f58..375afa48650d 100644
--- a/games-emulation/prosystem-jg/Manifest
+++ b/games-emulation/prosystem-jg/Manifest
@@ -1 +1 @@
-DIST prosystem-1.5.1.tar.bz2 49454 BLAKE2B 40c392805de577d2275c4810e36b6489a1457920484631bc63a54bef7c6120f5bef114bc52e17b65a43ccfc7c13b84694ea40376845217bae306a19940991a56 SHA512 daa3f40bc490299cdfb93393e95f411be7225dfe5271b2767ca7f5ef422ed053c3255b952de041ef44b7a196cb780b292f37a12104aef299c15ac564b77d281f
+DIST prosystem-1.5.2.tar.bz2 49674 BLAKE2B 700924f3d749a551337289a634c3f36801c9a57ac6a68c1940e65f1a6dfb1a8fef0fcf9b3227509656965bcff9e27112b6e847d11593400f22e0cf3706b12b05 SHA512 9e59d0c8e4edaf081e0ba0574a11fd3d24f12375345cbcba483f5d9a4be376fc5dcab3145e9f4deb117ebcdc69ae8da68643c27adfc9b7a42d79903ef7c15d11
diff --git a/games-emulation/prosystem-jg/prosystem-jg-1.5.1.ebuild b/games-emulation/prosystem-jg/prosystem-jg-1.5.1.ebuild
deleted file mode 100644
index 212b4dd7a4b3..000000000000
--- a/games-emulation/prosystem-jg/prosystem-jg-1.5.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_PN=${PN%-*}
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Jolly Good Fork of ProSystem"
-HOMEPAGE="https://gitlab.com/jgemu/prosystem"
-if [[ "${PV}" == *9999 ]] ; then
-	inherit git-r3
-	EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
-else
-	SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
-	S="${WORKDIR}/${MY_P}"
-	KEYWORDS="~amd64"
-fi
-
-LICENSE="BSD GPL-2+"
-SLOT="1"
-
-DEPEND="
-	media-libs/jg:1=
-"
-RDEPEND="
-	${DEPEND}
-	games-emulation/jgrf
-"
-BDEPEND="
-	virtual/pkgconfig
-"
-
-src_compile() {
-	emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_install() {
-	emake install \
-		DESTDIR="${D}" \
-		PREFIX="${EPREFIX}"/usr \
-		DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
-		LIBDIR="${EPREFIX}/usr/$(get_libdir)"
-}
diff --git a/games-emulation/prosystem-jg/prosystem-jg-1.5.2.ebuild b/games-emulation/prosystem-jg/prosystem-jg-1.5.2.ebuild
new file mode 100644
index 000000000000..212b4dd7a4b3
--- /dev/null
+++ b/games-emulation/prosystem-jg/prosystem-jg-1.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of ProSystem"
+HOMEPAGE="https://gitlab.com/jgemu/prosystem"
+if [[ "${PV}" == *9999 ]] ; then
+	inherit git-r3
+	EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+	SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+	S="${WORKDIR}/${MY_P}"
+	KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="1"
+
+DEPEND="
+	media-libs/jg:1=
+"
+RDEPEND="
+	${DEPEND}
+	games-emulation/jgrf
+"
+BDEPEND="
+	virtual/pkgconfig
+"
+
+src_compile() {
+	emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+	emake install \
+		DESTDIR="${D}" \
+		PREFIX="${EPREFIX}"/usr \
+		DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+		LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
-- 
cgit v1.2.3-65-gdbad