From 6264d1f4e26f9f6057f8237d834b848365c91ea8 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Mon, 13 Mar 2017 21:56:30 +0100
Subject: kde-frameworks/plasma: Fix Plasma folderview regression

KDE BUG https://bugs.kde.org/show_bug.cgi?id=377441

Package-Manager: Portage-2.3.3, Repoman-2.3.1
---
 .../files/plasma-5.32.0-prefix-qstringlist.patch   | 43 +++++++++++++
 kde-frameworks/plasma/plasma-5.32.0-r1.ebuild      | 70 ++++++++++++++++++++++
 2 files changed, 113 insertions(+)
 create mode 100644 kde-frameworks/plasma/files/plasma-5.32.0-prefix-qstringlist.patch
 create mode 100644 kde-frameworks/plasma/plasma-5.32.0-r1.ebuild

(limited to 'kde-frameworks')

diff --git a/kde-frameworks/plasma/files/plasma-5.32.0-prefix-qstringlist.patch b/kde-frameworks/plasma/files/plasma-5.32.0-prefix-qstringlist.patch
new file mode 100644
index 000000000000..460d1bd94eda
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.32.0-prefix-qstringlist.patch
@@ -0,0 +1,43 @@
+From 547a34d346695295ce05499ae355203414412993 Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Fri, 10 Mar 2017 09:49:47 +0000
+Subject: Handle applyPrefixes with an empty string
+
+Summary:
+When setting an empty QStringList as prefix, it can lead to unexpected results, such as the prefix not changing.
+
+BUG: 377441
+
+Reviewers: #plasma
+
+Subscribers: plasma-devel, #frameworks
+
+Tags: #plasma, #frameworks
+
+Differential Revision: https://phabricator.kde.org/D5000
+---
+ src/declarativeimports/core/framesvgitem.cpp | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/src/declarativeimports/core/framesvgitem.cpp b/src/declarativeimports/core/framesvgitem.cpp
+index 81f9e63..8e6225f 100644
+--- a/src/declarativeimports/core/framesvgitem.cpp
++++ b/src/declarativeimports/core/framesvgitem.cpp
+@@ -556,7 +556,13 @@ void FrameSvgItem::updateDevicePixelRatio()
+ 
+ void FrameSvgItem::applyPrefixes()
+ {
+-    if (m_prefixes.isEmpty() || m_frameSvg->imagePath().isEmpty()) {
++
++    if (m_frameSvg->imagePath().isEmpty()) {
++        return;
++    }
++
++    if (m_prefixes.isEmpty()) {
++        m_frameSvg->setElementPrefix(QString());
+         return;
+     }
+ 
+-- 
+cgit v0.11.2
+
diff --git a/kde-frameworks/plasma/plasma-5.32.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.32.0-r1.ebuild
new file mode 100644
index 000000000000..ba8af05f8de6
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.32.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KMNAME="${PN}-framework"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma framework"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="egl gles2 wayland X"
+
+COMMON_DEPEND="
+	$(add_frameworks_dep kactivities)
+	$(add_frameworks_dep karchive)
+	$(add_frameworks_dep kconfig)
+	$(add_frameworks_dep kconfigwidgets)
+	$(add_frameworks_dep kcoreaddons)
+	$(add_frameworks_dep kdeclarative)
+	$(add_frameworks_dep kglobalaccel)
+	$(add_frameworks_dep kguiaddons)
+	$(add_frameworks_dep ki18n)
+	$(add_frameworks_dep kiconthemes)
+	$(add_frameworks_dep kio)
+	$(add_frameworks_dep knotifications)
+	$(add_frameworks_dep kpackage)
+	$(add_frameworks_dep kservice)
+	$(add_frameworks_dep kwindowsystem)
+	$(add_frameworks_dep kxmlgui)
+	$(add_qt_dep qtdbus)
+	$(add_qt_dep qtdeclarative)
+	$(add_qt_dep qtgui 'gles2=')
+	$(add_qt_dep qtquickcontrols)
+	$(add_qt_dep qtsql)
+	$(add_qt_dep qtsvg)
+	$(add_qt_dep qtwidgets)
+	egl? ( media-libs/mesa[egl] )
+	!gles2? ( virtual/opengl )
+	wayland? ( $(add_frameworks_dep kwayland) )
+	X? (
+		$(add_qt_dep qtx11extras)
+		x11-libs/libX11
+		x11-libs/libxcb
+	)
+"
+DEPEND="${COMMON_DEPEND}
+	$(add_frameworks_dep kdoctools)
+	X? ( x11-proto/xproto )
+"
+RDEPEND="${COMMON_DEPEND}
+	!<kde-apps/kapptemplate-15.08.3-r1:5
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-prefix-qstringlist.patch" )
+
+src_configure() {
+	local mycmakeargs=(
+		$(cmake-utils_use_find_package egl EGL)
+		$(cmake-utils_use_find_package !gles2 OpenGL)
+		$(cmake-utils_use_find_package wayland KF5Wayland)
+		$(cmake-utils_use_find_package X X11)
+		$(cmake-utils_use_find_package X XCB)
+	)
+
+	kde5_src_configure
+}
-- 
cgit v1.2.3-65-gdbad