From e61f4b1adb000e97187c5eeefb8854dfaa60f853 Mon Sep 17 00:00:00 2001
From: Jeroen Roovers <jer@gentoo.org>
Date: Sat, 29 Aug 2020 13:13:23 +0200
Subject: net-analyzer/argus: Version 3.0.8.3

Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
---
 net-analyzer/argus/Manifest                        |  1 +
 net-analyzer/argus/argus-3.0.8.3.ebuild            | 95 ++++++++++++++++++++++
 net-analyzer/argus/files/argus-3.0.8.3-ar.patch    | 11 +++
 .../argus/files/argus-3.0.8.3-as-needed.patch      | 11 +++
 4 files changed, 118 insertions(+)
 create mode 100644 net-analyzer/argus/argus-3.0.8.3.ebuild
 create mode 100644 net-analyzer/argus/files/argus-3.0.8.3-ar.patch
 create mode 100644 net-analyzer/argus/files/argus-3.0.8.3-as-needed.patch

(limited to 'net-analyzer')

diff --git a/net-analyzer/argus/Manifest b/net-analyzer/argus/Manifest
index 17d6ac24042c..960cce267b55 100644
--- a/net-analyzer/argus/Manifest
+++ b/net-analyzer/argus/Manifest
@@ -1 +1,2 @@
 DIST argus-3.0.8.2.tar.gz 524749 BLAKE2B 4d93fd8acd71b198da712961d75f0e813f5ed3fde841e77b8a10c3a9b89571902b7597969a4be12437c97ffc69ba5ebefaee8b684c5d2d4ce4f1309c1cfd1199 SHA512 146795880d8697e065ed23d2fbab226846d55db0b71945c5a4cab2896e48ceb6e1671ccb4e00dc3b0f984525bac4ced3773f3b9e70c3ea5f7c6972fe9bd94313
+DIST argus-3.0.8.3.tar.gz 524549 BLAKE2B f905784c12d28d4440a7a6954441ce4f0865125a87e3d740edd5785e729f8b5b45967d97aef4f72802d2166b76176e15c6f15ec99b87ae1d14849ae92c65ad76 SHA512 f66db5b3bb1305825b76a7eda413d5805d65182aabef647e27716cfd629327b3aab8c299bc8af419199ac655cef4ac3bfcb83c059080e98b042e09f79f01d82a
diff --git a/net-analyzer/argus/argus-3.0.8.3.ebuild b/net-analyzer/argus/argus-3.0.8.3.ebuild
new file mode 100644
index 000000000000..8092871dded2
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.8.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools user
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="https://openargus.org/"
+SRC_URI="https://www.qosient.com/argus/dev/${P/_rc/.rc.}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug sasl tcpd"
+
+RDEPEND="
+	net-libs/libnsl:=
+	net-libs/libpcap
+	net-libs/libtirpc
+	sys-libs/zlib
+	sasl? ( dev-libs/cyrus-sasl )
+	tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+"
+
+DEPEND="
+	${RDEPEND}
+	>=sys-devel/bison-1.28
+	>=sys-devel/flex-2.4.6
+"
+PATCHES=(
+	"${FILESDIR}"/${PN}-3.0.8.1-disable-tcp-wrappers-automagic.patch
+	"${FILESDIR}"/${PN}-3.0.5-Makefile.patch
+	"${FILESDIR}"/${PN}-3.0.7.3-DLT_IPNET.patch
+	"${FILESDIR}"/${PN}-3.0.8.3-ar.patch
+	"${FILESDIR}"/${PN}-3.0.8.3-as-needed.patch
+)
+S=${WORKDIR}/${P/_rc/.rc.}
+
+pkg_setup() {
+	enewgroup argus
+	enewuser argus -1 -1 /var/lib/argus argus
+}
+
+src_prepare() {
+	find . -type f -execdir chmod +w {} \; #561360
+	sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+		-i argus/argus.c \
+		-i support/Config/argus.conf \
+		-i man/man8/argus.8 \
+		-i man/man5/argus.conf.5 || die
+
+	sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+		-e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+		-e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+			-i support/Config/argus.conf || die
+
+	default
+	eautoreconf
+}
+
+src_configure() {
+	use debug && touch .debug # enable debugging
+
+	econf \
+		$(use_with sasl) \
+		$(use_with tcpd wrappers)
+}
+
+src_compile() {
+	emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+	doman man/man5/*.5 man/man8/*.8
+
+	dosbin bin/argus{,bug}
+
+	dodoc ChangeLog CREDITS README
+
+	insinto /etc/argus
+	doins support/Config/argus.conf
+
+	newinitd "${FILESDIR}/argus.initd" argus
+	keepdir /var/lib/argus
+}
+
+pkg_preinst() {
+	enewgroup argus
+	enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+	elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+	elog "possible that the init script will fail to work."
+}
diff --git a/net-analyzer/argus/files/argus-3.0.8.3-ar.patch b/net-analyzer/argus/files/argus-3.0.8.3-ar.patch
new file mode 100644
index 000000000000..d17a1d3ff06f
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.8.3-ar.patch
@@ -0,0 +1,11 @@
+--- a/common/Makefile.in
++++ b/common/Makefile.in
+@@ -87,7 +87,7 @@
+ all: $(LIBS)
+ 
+ @INSTALL_LIB@/argus_common.a: $(COMMONOBJ)
+-	rm -f $@; ar qc $@ $(COMMONOBJ)
++	rm -f $@; $(AR) qc $@ $(COMMONOBJ)
+ 	-$(RANLIB) $@
+ 
+ scanner.c: scanner.l 
diff --git a/net-analyzer/argus/files/argus-3.0.8.3-as-needed.patch b/net-analyzer/argus/files/argus-3.0.8.3-as-needed.patch
new file mode 100644
index 000000000000..b9616d305e01
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.8.3-as-needed.patch
@@ -0,0 +1,11 @@
+--- a/argus/Makefile.in
++++ b/argus/Makefile.in
+@@ -85,7 +85,7 @@
+ 
+ OBJ =	$(SRC:.c=.o)
+ 
+-LIB = @LIBS@ @V_THREADS@ $(WRAPLIBS) $(SASLLIBS) $(XDRLIBS) $(COMPATLIB) ../lib/argus_common.a -lm
++LIB = ../lib/argus_common.a @LIBS@ @V_THREADS@ $(WRAPLIBS) $(SASLLIBS) $(XDRLIBS) $(COMPATLIB) -lm
+ 
+ HDR =	pcap.h pcap-int.h pcap-namedb.h pcap-nit.h pcap-pf.h \
+ 	ethertype.h gencode.h gnuc.h
-- 
cgit v1.2.3-65-gdbad