From b8097255df6404179090bfad8e77e7444d2d73ee Mon Sep 17 00:00:00 2001
From: "Anthony G. Basile" <blueness@gentoo.org>
Date: Wed, 2 Sep 2015 20:18:13 -0400
Subject: net-misc/stunnel: version bumpt to 5.23

Package-Manager: portage-2.2.20.1
---
 net-misc/stunnel/Manifest            |  1 +
 net-misc/stunnel/stunnel-5.23.ebuild | 89 ++++++++++++++++++++++++++++++++++++
 2 files changed, 90 insertions(+)
 create mode 100644 net-misc/stunnel/stunnel-5.23.ebuild

(limited to 'net-misc')

diff --git a/net-misc/stunnel/Manifest b/net-misc/stunnel/Manifest
index c67f0238393b..3d2ecf1e506b 100644
--- a/net-misc/stunnel/Manifest
+++ b/net-misc/stunnel/Manifest
@@ -4,3 +4,4 @@ DIST stunnel-5.18.tar.gz 624660 SHA256 0532c0a2f8de3da1ab625e384146501ce5936fac6
 DIST stunnel-5.19.tar.gz 620810 SHA256 0b543242cf26649acfdd9f00de564c3e8de7ac2237d53935ffdc7eb24f4d556d SHA512 93b1b6f62873610dada98b7d555aafa8495f9d34fd2a9b92e2bc6420edbc087f428ca6d6d47560055b36809fad08ec7eb41e71bc0abe97c84277125484866574 WHIRLPOOL 5fbab7761a7284766b65bac177bd997ac506141627992bc7f8642250a99d6dd7dc09a2a609934aa66ad99ba7faa2cf886edb2d0b1b942d672671aff57cbf3d48
 DIST stunnel-5.20.tar.gz 625091 SHA256 4a36a3729a7287d9d82c4b38bf72c4d3496346cb969b86129c5deac22b20292b SHA512 59262aacf866cac25bac707b94c5a6185aa868b5fdfab38a9ef03a00b80f106d92e2872c0b0fecbc5d13adb7bdea7f922768fb78f38355dbf67eb34a148441e4 WHIRLPOOL fc890dff4ddeb00df9e8ea84fae8f0f23609d1356c91d4cdeade55f164bad322a8a2df72955b710e46e1f74a33bbc7f5c8d734efc190d0835056926d7c902b26
 DIST stunnel-5.22.tar.gz 627014 SHA256 8ad628a6948153cdb2044283f6988384a30585ea7e14778c2ee616a6678cb83f SHA512 edf48fda7d431eee79feb72b6901c02d667ae25f85db9850e12776b57cc68ccacdf069deb3858106939b5c3c53b682a785083f5e7241221a350e06f4307e74f5 WHIRLPOOL f467f91976100e2941ac9809199ce229655daaaee2ebd83eebe525499cb670b1577ddb7b3a65ae2a15d36c925a4747db402d969b9589c698a5d0d52508705f44
+DIST stunnel-5.23.tar.gz 630943 SHA256 0fc4a702afd2e857bae8ad1f39c51546eb282c3d0ff4f4d55d62aece7328ddea SHA512 f312b5feff78548a7d1e7785068f0a0e3dd3785541f09d5850f9f5c5ee6bdf63b30761d68c3ba17465e87b048acd47e613aab139aab540873a38594f68669cb9 WHIRLPOOL dd32db35f2b09c3414471dd45d74369156a909429cf2becf34e08854d838d8c3c3979fb0b7e9e524a2e01abe7740ea0ac320985bb6dd813081296168ed7f1819
diff --git a/net-misc/stunnel/stunnel-5.23.ebuild b/net-misc/stunnel/stunnel-5.23.ebuild
new file mode 100644
index 000000000000..29080ccb350c
--- /dev/null
+++ b/net-misc/stunnel/stunnel-5.23.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit ssl-cert eutils multilib systemd user
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://www.stunnel.org/index.html"
+SRC_URI="ftp://ftp.stunnel.org/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+	http://www.usenix.org.uk/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+	http://ftp.nluug.nl/pub/networking/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+	http://www.namesdir.com/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+	http://stunnel.cybermirror.org/archive/${PV%%.*}.x/${P}.tar.gz
+	http://mirrors.zerg.biz/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+	ftp://mirrors.go-parts.com/stunnel/archive/${PV%%.*}.x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6 selinux stunnel3 tcpd"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+	dev-libs/openssl:="
+RDEPEND="${DEPEND}
+	stunnel3? ( dev-lang/perl )
+	selinux? ( sec-policy/selinux-stunnel )"
+
+RESTRICT="test"
+
+pkg_setup() {
+	enewgroup stunnel
+	enewuser stunnel -1 -1 -1 stunnel
+}
+
+src_prepare() {
+	# Hack away generation of certificate
+	sed -i -e "s/^install-data-local:/do-not-run-this:/" \
+		tools/Makefile.in || die "sed failed"
+
+	echo "CONFIG_PROTECT=\"/etc/stunnel/stunnel.conf\"" > "${T}"/20stunnel
+}
+
+src_configure() {
+	econf \
+		--libdir="${EPREFIX}/usr/$(get_libdir)" \
+		$(use_enable ipv6) \
+		$(use_enable tcpd libwrap) \
+		--with-ssl="${EPREFIX}"/usr \
+		--disable-fips
+}
+
+src_install() {
+	emake DESTDIR="${D}" install
+	rm -rf "${ED}"/usr/share/doc/${PN}
+	rm -f "${ED}"/etc/stunnel/stunnel.conf-sample \
+		"${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
+	use stunnel3 || rm -f "${ED}"/usr/bin/stunnel3
+
+	# The binary was moved to /usr/bin with 4.21,
+	# symlink for backwards compatibility
+	dosym ../bin/stunnel /usr/sbin/stunnel
+
+	dodoc AUTHORS BUGS CREDITS PORTS README TODO ChangeLog
+	dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+		tools/importCA.html
+
+	insinto /etc/stunnel
+	doins "${FILESDIR}"/stunnel.conf
+	doinitd "${FILESDIR}"/stunnel
+
+	doenvd "${T}"/20stunnel
+
+	systemd_dounit "${S}/tools/stunnel.service"
+	systemd_newtmpfilesd "${FILESDIR}"/stunnel.tmpfiles.conf stunnel.conf
+}
+
+pkg_postinst() {
+	if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
+		install_cert /etc/stunnel/stunnel
+		chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+		chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+	fi
+
+	einfo "If you want to run multiple instances of stunnel, create a new config"
+	einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
+	einfo "\'pid= \' with a unique filename."
+}
-- 
cgit v1.2.3-65-gdbad