summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-08-19 21:40:04 +0000
committerMarinus Schraal <foser@gentoo.org>2004-08-19 21:40:04 +0000
commitaa16cba7de83b27cff04d00e736b519f4f518cc6 (patch)
tree02d52aeb5dd43c9dbf2b5589f31940b23b44a370 /app-dicts/stardict
parentRemoved old version (diff)
downloadhistorical-aa16cba7de83b27cff04d00e736b519f4f518cc6.tar.gz
historical-aa16cba7de83b27cff04d00e736b519f4f518cc6.tar.bz2
historical-aa16cba7de83b27cff04d00e736b519f4f518cc6.zip
gtk+ fixes of old
Diffstat (limited to 'app-dicts/stardict')
-rw-r--r--app-dicts/stardict/ChangeLog5
-rw-r--r--app-dicts/stardict/Manifest8
-rw-r--r--app-dicts/stardict/files/digest-stardict-2.4.01
-rw-r--r--app-dicts/stardict/stardict-2.2.1.ebuild15
-rw-r--r--app-dicts/stardict/stardict-2.4.0.ebuild51
-rw-r--r--app-dicts/stardict/stardict-2.4.1.ebuild16
6 files changed, 36 insertions, 60 deletions
diff --git a/app-dicts/stardict/ChangeLog b/app-dicts/stardict/ChangeLog
index e1467e6895f7..e37322ec7377 100644
--- a/app-dicts/stardict/ChangeLog
+++ b/app-dicts/stardict/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-dicts/stardict
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/ChangeLog,v 1.17 2004/06/24 21:45:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/ChangeLog,v 1.18 2004/08/19 21:40:04 foser Exp $
+
+ 19 Aug 2004; foser <foser@gentoo.org> stardict-2.2.1,2.4.1.ebuild :
+ Also fix for gtk+-2.4 issues (#45791)
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> stardict-2.4.2.ebuild:
Add inherit eutils
diff --git a/app-dicts/stardict/Manifest b/app-dicts/stardict/Manifest
index 3730a8a40593..518579c028d4 100644
--- a/app-dicts/stardict/Manifest
+++ b/app-dicts/stardict/Manifest
@@ -1,13 +1,11 @@
-MD5 40daec3a1b4b9978668909a3cb933d8b stardict-2.4.0.ebuild 1459
-MD5 10491d93ba6243882bf96e2bdbb4db7f stardict-2.2.1.ebuild 1458
+MD5 cb6a512c507bb0752c9b9210b9876490 stardict-2.2.1.ebuild 1796
MD5 8da32d249d6b4cfd7ae1c21da57e9ce3 stardict-2.4.2.ebuild 1763
-MD5 18e961dee96a7fff47bbc91b35bcfe84 stardict-2.4.1.ebuild 1482
-MD5 f43598453231362e91dacf64bc642d57 ChangeLog 2969
+MD5 c48f7d3ed14dceb53f2d6a0bbc519ae9 stardict-2.4.1.ebuild 1817
+MD5 dfb7f2f0c3defbf5b8a5a50d01f10893 ChangeLog 3077
MD5 b1119d84c7a4c3535572b94ec508e907 metadata.xml 215
MD5 40e8df6800d5f7bf138a3a6692854a56 files/stardict-gentoo.patch 547
MD5 b41107d5daeb5414fa21b3f9905e105c files/stardict-config.sh 565
MD5 9f2bc974d89734beae9aa192bafc68ef files/stardict-gtk24.patch 1210
MD5 3316b188ec45fd4d24db494c5990c20b files/digest-stardict-2.2.1 67
-MD5 c08bafc9808a52a742f5794f68a9327b files/digest-stardict-2.4.0 67
MD5 38728c3a0ad675dd5f23d72cb143741a files/digest-stardict-2.4.1 67
MD5 390090b978f088147ce59b0308822093 files/digest-stardict-2.4.2 67
diff --git a/app-dicts/stardict/files/digest-stardict-2.4.0 b/app-dicts/stardict/files/digest-stardict-2.4.0
deleted file mode 100644
index ec63633b8c80..000000000000
--- a/app-dicts/stardict/files/digest-stardict-2.4.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a2754c9cb2a97a63263dd5a619c2930e stardict-2.4.0.tar.bz2 625105
diff --git a/app-dicts/stardict/stardict-2.2.1.ebuild b/app-dicts/stardict/stardict-2.2.1.ebuild
index 97abd87a3eaa..79c155305fed 100644
--- a/app-dicts/stardict/stardict-2.2.1.ebuild
+++ b/app-dicts/stardict/stardict-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.2.1.ebuild,v 1.7 2004/06/24 21:45:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.2.1.ebuild,v 1.8 2004/08/19 21:40:04 foser Exp $
inherit gnome2
@@ -49,3 +49,16 @@ pkg_postinst() {
echo
einfo " emerge -s stardict-"
}
+
+CFLAGS="${CFLAGS} -UG_DISABLE_DEPRECATED \
+ -UGDK_DISABLE_DEPRECATED \
+ -UGDK_PIXBUF_DISABLE_DEPRECATED \
+ -UGTK_DISABLE_DEPRECATED \
+ -UGNOME_DISABLE_DEPRECATED"
+
+CXXFLAGS="${CXXFLAGS} -UG_DISABLE_DEPRECATED \
+ -UGDK_DISABLE_DEPRECATED \
+ -UGDK_PIXBUF_DISABLE_DEPRECATED \
+ -UGTK_DISABLE_DEPRECATED \
+ -UGNOME_DISABLE_DEPRECATED"
+
diff --git a/app-dicts/stardict/stardict-2.4.0.ebuild b/app-dicts/stardict/stardict-2.4.0.ebuild
deleted file mode 100644
index 636feb47cfbc..000000000000
--- a/app-dicts/stardict/stardict-2.4.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.0.ebuild,v 1.5 2004/06/24 21:45:23 agriffis Exp $
-
-inherit gnome2
-
-# NOTE: Even though the *.dict.dz are the same as dictd/freedict's files,
-# their indexes seem to be in a different format. So we'll keep them
-# seperate for now.
-
-IUSE=""
-DESCRIPTION="A GNOME2 international dictionary supporting fuzzy and glob style matching"
-HOMEPAGE="http://stardict.sourceforge.net/ http://cosoft.org.cn/projects/stardict/"
-SRC_URI="mirror://sourceforge/stardict/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-# when adding keywords, remember to add to stardict.eclass
-KEYWORDS="x86 ~ppc"
-
-
-RDEPEND=">=gnome-base/libbonobo-2.2.0
- >=gnome-base/libgnome-2.2.0
- >=gnome-base/libgnomeui-2.2.0
- >=sys-libs/zlib-1.1.4
- >=gnome-base/gconf-1.2
- >=dev-libs/popt-1.7
- >=gnome-base/ORBit2-2.6
- >=x11-libs/gtk+-2"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- gnome2_omf_fix
-}
-
-src_install() {
- gnome2_src_install
- # dictionary index generation files
- insinto /usr/share/stardict/tools
- doins ${S}/tools/{dictd2dic,directory2dict,olddic2newdic,oxford2dic,pydict2dict,wquick2dict}
-}
-
-pkg_postinst() {
- einfo "You will now need to install stardict dictionary files. If"
- einfo "you have not, execute the below to get a list of dictionaries:"
- echo
- einfo " emerge -s stardict-"
-}
diff --git a/app-dicts/stardict/stardict-2.4.1.ebuild b/app-dicts/stardict/stardict-2.4.1.ebuild
index 3b2e58468567..50ffdcdaa077 100644
--- a/app-dicts/stardict/stardict-2.4.1.ebuild
+++ b/app-dicts/stardict/stardict-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.1.ebuild,v 1.5 2004/06/24 21:45:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.1.ebuild,v 1.6 2004/08/19 21:40:04 foser Exp $
inherit gnome2
@@ -50,3 +50,17 @@ pkg_postinst() {
echo
einfo " emerge -s stardict-"
}
+
+CFLAGS="${CFLAGS} \
+ -UG_DISABLE_DEPRECATED \
+ -UGDK_DISABLE_DEPRECATED \
+ -UGDK_PIXBUF_DISABLE_DEPRECATED \
+ -UGTK_DISABLE_DEPRECATED \
+ -UGNOME_DISABLE_DEPRECATED"
+
+CXXFLAGS="${CXXFLAGS} \
+ -UG_DISABLE_DEPRECATED \
+ -UGDK_DISABLE_DEPRECATED \
+ -UGDK_PIXBUF_DISABLE_DEPRECATED \
+ -UGTK_DISABLE_DEPRECATED \
+ -UGNOME_DISABLE_DEPRECATED"