summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-09-02 12:15:41 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-09-02 12:15:41 +0000
commit11e51731fca468b441973c926dd5d87c8f280c5a (patch)
tree0309e5d2ccbf01169247687575eb33b45869c2c7 /app-emulation/bochs
parentChanged chown as requested by gentoo bsd team. Fixed bug #103563. (diff)
downloadhistorical-11e51731fca468b441973c926dd5d87c8f280c5a.tar.gz
historical-11e51731fca468b441973c926dd5d87c8f280c5a.tar.bz2
historical-11e51731fca468b441973c926dd5d87c8f280c5a.zip
fix for bug #104119, wxwidget eclass behaviour
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog5
-rw-r--r--app-emulation/bochs/Manifest4
-rw-r--r--app-emulation/bochs/bochs-2.2.1.ebuild6
3 files changed, 10 insertions, 5 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index af5cb734aadb..38d4f395edd4 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.45 2005/08/29 10:25:35 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.46 2005/09/02 12:15:41 lu_zero Exp $
+
+ 02 Sep 2005; Luca Barbato <lu_zero@gentoo.org> bochs-2.2.1.ebuild:
+ fix for bug #104119
29 Aug 2005; Luca Barbato <lu_zero@gentoo.org> bochs-2.2.1.ebuild:
Fix a typo, thanks to Karl-Johan Karlsson
diff --git a/app-emulation/bochs/Manifest b/app-emulation/bochs/Manifest
index add3e3bfe9c4..6b07cb7c9e98 100644
--- a/app-emulation/bochs/Manifest
+++ b/app-emulation/bochs/Manifest
@@ -1,8 +1,8 @@
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
MD5 b378526dea0a003eeab6481bd2020897 bochs-2.1.ebuild 2144
MD5 273efd5c1f0e06fbb9620b9583d6398c bochs-2.1.1.ebuild 2408
-MD5 21c7d0e2a7db2c7b16a6261d56b698aa ChangeLog 5119
-MD5 5217e86315cc30a4221c2953778d91f7 bochs-2.2.1.ebuild 2400
+MD5 cc19688fea0a64ded2a127d90be38c15 ChangeLog 5211
+MD5 151fc7b33a1a8c17f862c4b458b7cd2b bochs-2.2.1.ebuild 2424
MD5 f95b73bcfb4c045d563032c0b0b824c7 files/digest-bochs-2.2.1 126
MD5 8e9513ab2651bd41c0529405d45d3da1 files/digest-bochs-2.1 124
MD5 207a406a1a47e2650e396ea0976f5206 files/digest-bochs-2.1.1 126
diff --git a/app-emulation/bochs/bochs-2.2.1.ebuild b/app-emulation/bochs/bochs-2.2.1.ebuild
index 07f07ccd7546..044851a22dc3 100644
--- a/app-emulation/bochs/bochs-2.2.1.ebuild
+++ b/app-emulation/bochs/bochs-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.2.1.ebuild,v 1.4 2005/08/29 10:25:35 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.2.1.ebuild,v 1.5 2005/09/02 12:15:41 lu_zero Exp $
inherit eutils wxwidgets
@@ -17,7 +17,7 @@ IUSE="debugger gtk2 readline sdl wxwindows"
RDEPEND="virtual/libc
virtual/x11
sdl? ( media-libs/libsdl )
- wxwindows? ( >=x11-libs/wxGTK-2.4 )
+ wxwindows? ( >=x11-libs/wxGTK-2.6 )
readline? ( sys-libs/readline )"
DEPEND="${RDEPEND}
>=sys-apps/sed-4
@@ -39,6 +39,8 @@ src_unpack() {
}
src_compile() {
+ export WX_GTK_VER=2.6
+
use wxwindows && \
if ! use gtk2 ; then
need-wxwidgets gtk