summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2004-01-08 04:27:30 +0000
committerLars Weiler <pylon@gentoo.org>2004-01-08 04:27:30 +0000
commite24ac3cd68c638d89b4449119f2c007f653284da (patch)
treec2a7001c132e2390eb58d2eaeeac3acbd936b3df /app-emulation/mol
parentadded hdf5 local flag for octave (diff)
downloadhistorical-e24ac3cd68c638d89b4449119f2c007f653284da.tar.gz
historical-e24ac3cd68c638d89b4449119f2c007f653284da.tar.bz2
historical-e24ac3cd68c638d89b4449119f2c007f653284da.zip
version bump
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/Manifest4
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.69_pre71
-rw-r--r--app-emulation/mol/mol-0.9.69_pre7.ebuild93
3 files changed, 96 insertions, 2 deletions
diff --git a/app-emulation/mol/Manifest b/app-emulation/mol/Manifest
index f2f9e6c8540d..01e8f72432a7 100644
--- a/app-emulation/mol/Manifest
+++ b/app-emulation/mol/Manifest
@@ -1,10 +1,10 @@
-MD5 ecee60434a8f7eb4fd84d8cec1306588 ChangeLog 5340
+MD5 a2652b40c53aa30fb7787a1a8609aa6a ChangeLog 5340
MD5 3263d375abba2d098c636efc2b135ea5 metadata.xml 333
MD5 84c32ed763ae9c3851d03607a6bd1684 mol-0.9.68-r4.ebuild 2217
MD5 916962c262a207a28e8e9e9fa27f8538 mol-0.9.69_pre3.ebuild 2256
MD5 d7e93f442ec1c3255e5db4e50fc74228 mol-0.9.69_pre5.ebuild 3064
MD5 8b4045ce37e898fc09e32c369a13239e mol-0.9.69_pre6.ebuild 3156
-MD5 e5f9d43937b062bb6a1e1e557d6a66f3 mol-0.9.69_pre7.ebuild 3013
+MD5 191f6330f6d1c4707577b2e209586e87 mol-0.9.69_pre7.ebuild 3013
MD5 98990df6bb9f196021dea0b77d2d912d files/26-arch-fix.patch 2320
MD5 d4bc3f0122eb77fbfbfcf584f442049d files/digest-mol-0.9.68-r4 67
MD5 fe988b32af2da567155820691a274880 files/digest-mol-0.9.69_pre3 69
diff --git a/app-emulation/mol/files/digest-mol-0.9.69_pre7 b/app-emulation/mol/files/digest-mol-0.9.69_pre7
new file mode 100644
index 000000000000..ea5e04ec6ca9
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.69_pre7
@@ -0,0 +1 @@
+MD5 d6fac7c02619d1537a2b5c59251b2be8 mol-0.9.69_pre7.tar.bz2 2487169
diff --git a/app-emulation/mol/mol-0.9.69_pre7.ebuild b/app-emulation/mol/mol-0.9.69_pre7.ebuild
new file mode 100644
index 000000000000..d5673d512051
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.69_pre7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.69_pre7.ebuild,v 1.1 2004/01/08 04:27:20 pylon Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="net-misc/dhcp
+ net-firewall/iptables
+ alsa? ( virtual/alsa )
+ esd? ( media-sound/esound )
+ X? ( virtual/x11 )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~ppc64 -x86 -sparc -alpha -mips"
+IUSE="alsa esd debug oldworld X"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/26-arch-fix.patch || die
+}
+
+src_compile() {
+
+ local myconf
+ use alsa || myconf="${myconf} --disable-alsa"
+ use debug || myconf="${myconf} --disable-debugger"
+ use esd && myconf="${myconf} --enable-esd"
+ use oldworld || myconf="${myconf} --disable-oldworld"
+ use X && myconf="${myconf} --with-x"
+
+ einfo "MOL will be build with the following options:"
+ einfo "${myconf}"
+
+ filter-flags -fsigned-char
+
+ # dhcp config fix and show dchpd messages on starting mol
+ cd ${S}
+ sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
+ sed -i "s:DHCPD\ -q\ -cf:DHCPD\ -cf:g" Doc/config/tunconfig || die
+ export KERNEL_SOURCE="/usr/src/linux"
+ ./autogen.sh
+ ./configure ${myconf} --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+
+ addwrite "/usr/src/${FK}"
+
+ emake || die
+}
+
+src_install() {
+
+ # MOL needs write access to some .depend-files in the kernel-dir
+ # (at least arch/ppc/) to build the kernel-modules. With
+ # sandboxing enabled this would result in an access violation.
+
+ addwrite "/usr/src/${FK}"
+ emake DESTDIR=${D} install || die "Failed to install MOL."
+
+ dodoc 0README BUILDING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ echo
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol."
+ einfo "You might want to configure video modes first with molvconfig."
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " http://www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ echo
+ ewarn "For networking and sound you might install the drivers in the"
+ ewarn "folder \"MOL-Install\" on your Mac OS X-Desktop."
+ echo
+ ewarn "If errors with networking occur, make sure you have the following"
+ ewarn "kernel functions enabled:"
+ einfo "For the dhcp server:"
+ einfo " Socket Filtering (CONFIG_FILTER)"
+ einfo " Packet Socket (CONFIG_PACKET)"
+ einfo "For NAT:"
+ einfo " Network packet filtering (CONFIG_NETFILTER)"
+ einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
+ einfo " Full NAT (CONFIG_IP_NF_NAT)"
+ einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ echo
+}