summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-07 19:26:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-07 19:26:15 +0000
commit935dd75d471d74bc5ba6e36470bca71dc5d6f824 (patch)
tree334b2e21b9202a04ed29688f026cf5f082c4d656 /app-emulation/point2play
parentfixed sidplay-libs ebuild (diff)
downloadhistorical-935dd75d471d74bc5ba6e36470bca71dc5d6f824.tar.gz
historical-935dd75d471d74bc5ba6e36470bca71dc5d6f824.tar.bz2
historical-935dd75d471d74bc5ba6e36470bca71dc5d6f824.zip
ver bump #30556
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/ChangeLog7
-rw-r--r--app-emulation/point2play/files/1.1.1-python2.2.patch38
-rw-r--r--app-emulation/point2play/files/digest-point2play-1.1.1-r11
-rw-r--r--app-emulation/point2play/metadata.xml13
-rw-r--r--app-emulation/point2play/point2play-1.1.1-r1.ebuild34
5 files changed, 92 insertions, 1 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 69118bb74aaa..420cf2436b15 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/point2play
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.3 2003/10/06 23:34:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.4 2003/10/07 19:26:15 vapier Exp $
+
+*point2play-1.1.1-r1 (07 Oct 2003)
+
+ 07 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Patch around missing python 2.3 oss support #30556.
*point2play-1.1.1 (06 Oct 2003)
diff --git a/app-emulation/point2play/files/1.1.1-python2.2.patch b/app-emulation/point2play/files/1.1.1-python2.2.patch
new file mode 100644
index 000000000000..fd24b7762af5
--- /dev/null
+++ b/app-emulation/point2play/files/1.1.1-python2.2.patch
@@ -0,0 +1,38 @@
+--- usr/lib/transgaming_point2play/tests/test_sound.py.orig 2003-09-16 14:04:31.000000000 -0400
++++ usr/lib/transgaming_point2play/tests/test_sound.py 2003-10-07 15:17:36.044822360 -0400
+@@ -12,14 +12,21 @@
+ import wave
+ import os, os.path
+
+-import ossaudiodev
+-
++disable_oss = 0;
++try:
++ import ossaudiodev
++except:
++ print "Python 2.3 not found. Disabling oss audio tests."
++ disable_oss = 1;
+
+ TESTS = (_("Test For Sound Support"), "tgtest_sound", False),
+
+ def tgtest_sound():
+ """runs a test to ensure that sound output is working"""
+
++ if disable_oss:
++ return ((_('Basic sound test'), _('Test is disabled.'), 'red'),)
++
+ try:
+ try:
+ P2PPATH=os.environ["P2PPATH"] + "/"
+@@ -56,6 +63,11 @@
+ return ((_('Basic sound test'), _('Completed successfully\nDid you hear the sound?'), 'green'),)
+
+ def tgtest_sound_description():
++ if disable_oss:
++ return _('This test has been disabled.\n') + \
++ _('Please see:\n') + \
++ _('http://bugs.gentoo.org/show_bug.cgi?id=30556\n') + \
++ _('for more information.')
+ return _('This test attempts to play a sound\n') + \
+ _('file at 44 khz. This test uses the\n') + \
+ _('same method as WineX to play sound\n') + \
diff --git a/app-emulation/point2play/files/digest-point2play-1.1.1-r1 b/app-emulation/point2play/files/digest-point2play-1.1.1-r1
new file mode 100644
index 000000000000..a3832fe14f20
--- /dev/null
+++ b/app-emulation/point2play/files/digest-point2play-1.1.1-r1
@@ -0,0 +1 @@
+MD5 28c4923267e19d2cb61133783ca16858 point2play-small-1.1.1.tgz 562688
diff --git a/app-emulation/point2play/metadata.xml b/app-emulation/point2play/metadata.xml
new file mode 100644
index 000000000000..7b3d59c9dca8
--- /dev/null
+++ b/app-emulation/point2play/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>wine</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+<longdescription>
+Point2Play, a new intuitive user interface, debuts with this release to help novice users
+easily deal with configuration issues and experienced users gain greater system control.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emulation/point2play/point2play-1.1.1-r1.ebuild b/app-emulation/point2play/point2play-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..2acf2fecc6ac
--- /dev/null
+++ b/app-emulation/point2play/point2play-1.1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.1.1-r1.ebuild,v 1.1 2003/10/07 19:26:15 vapier Exp $
+
+MY_P=${PN}-small-${PV}
+DESCRIPTION="graphical frontend for WineX"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="x86"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.0
+ >=dev-python/pygtk-1.99.16
+ >=x11-themes/gtk-engines-metal-2.2.0"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Point2Play archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ echo
+ einfo "The archive should then be placed into ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-python2.2.patch
+}
+
+src_install() {
+ mv ${WORKDIR}/usr ${D}
+}