summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-11-22 11:18:28 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-11-22 11:18:28 +0000
commit82061a9bb1b806c461cf4d042908f330c68c3150 (patch)
tree61bb8be4f4cfd801ccabfa77d2d0addc3c000837 /app-emulation
parentAdd QA variable indicating which files contain textrels; these are a feature ... (diff)
downloadhistorical-82061a9bb1b806c461cf4d042908f330c68c3150.tar.gz
historical-82061a9bb1b806c461cf4d042908f330c68c3150.tar.bz2
historical-82061a9bb1b806c461cf4d042908f330c68c3150.zip
Add QA variables for textrels (a feature of how qemu works) and execstack/wx_load (due to a foreign binary).
Package-Manager: portage-2.1.2_rc2-r1
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog10
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild11
2 files changed, 18 insertions, 3 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 713d29c5752d..debd60e45843 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.26 2006/08/18 12:23:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.27 2006/11/22 11:18:28 kevquinn Exp $
+
+ 22 Nov 2006; Kevin F. Quinn <kevquinn@gentoo.org>
+ qemu-softmmu-0.8.2-r1.ebuild:
+ Add QA variables indicating which files contain textrels, require
+ execstack, and contain WX PT_LOAD segments. The TEXTRELs are a feature of how
+ qemu works. The execstack/wx_load markings are for a foreign binary.
18 Aug 2006; Luca Barbato <lu_zero@gentoo.org> qemu-softmmu-0.8.2.ebuild:
remove stray dep
@@ -80,7 +86,7 @@
x86 stable for qemu-softmmu-0.8.0 bug #123972.
08 Jan 2006; Luca Barbato <lu_zero@gentoo.org> qemu-softmmu-0.8.0.ebuild:
- Disable gcc checks, thanks to Robert Führicht <the_master_of_disaster@gmx.at>
+ Disable gcc checks, thanks to Robert FÃŒhricht <the_master_of_disaster@gmx.at>
*qemu-softmmu-0.8.0 (23 Dec 2005)
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild
index 9c73c4bab7d5..9b42ed1b3691 100644
--- a/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild,v 1.2 2006/08/17 08:09:42 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.8.2-r1.ebuild,v 1.3 2006/11/22 11:18:28 kevquinn Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -24,6 +24,15 @@ RDEPEND="sdl? ( media-libs/libsdl )"
S="${WORKDIR}/${P/-softmmu/}"
+QA_TEXTRELS="usr/bin/qemu
+ usr/bin/qemu-system-sparc
+ usr/bin/qemu-system-arm
+ usr/bin/qemu-system-ppc
+ usr/bin/qemu-system-mips
+ usr/bin/qemu-system-x86_64"
+QA_EXECSTACK="usr/share/qemu/openbios-sparc32"
+QA_WX_LOAD="usr/share/qemu/openbios-sparc32"
+
set_target_list() {
TARGET_LIST="i386-softmmu ppc-softmmu sparc-softmmu x86_64-softmmu arm-softmmu mips-softmmu"
export TARGET_LIST