summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-07-03 07:43:27 +0000
committerAlin Năstac <mrness@gentoo.org>2005-07-03 07:43:27 +0000
commitce73513873028f08b84b96ad7003733d52d4bc0a (patch)
tree4b13d616e52963e89951e01ce368d16f2e704063 /app-mobilephone
parent060 release (diff)
downloadhistorical-ce73513873028f08b84b96ad7003733d52d4bc0a.tar.gz
historical-ce73513873028f08b84b96ad7003733d52d4bc0a.tar.bz2
historical-ce73513873028f08b84b96ad7003733d52d4bc0a.zip
fix callergroup on Nokia 6230 (#97603)
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gammu/ChangeLog8
-rw-r--r--app-mobilephone/gammu/Manifest19
-rw-r--r--app-mobilephone/gammu/files/digest-gammu-1.01.0-r11
-rw-r--r--app-mobilephone/gammu/files/gammu-1.01.0-caller.patch26
-rw-r--r--app-mobilephone/gammu/gammu-1.01.0-r1.ebuild57
5 files changed, 107 insertions, 4 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index e647eef8fc5b..377f58e501d3 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/gammu
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.3 2005/06/12 15:09:18 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.4 2005/07/03 07:43:27 mrness Exp $
+
+*gammu-1.01.0-r1 (03 Jul 2005)
+
+ 03 Jul 2005; Alin Nastac <mrness@gentoo.org>
+ +files/gammu-1.01.0-caller.patch, +gammu-1.01.0-r1.ebuild:
+ Fix problem with caller groups on Nokia 6230 (#97603).
12 Jun 2005; Lars Weiler <pylon@gentoo.org> gammu-1.01.0.ebuild:
Stable on ppc.
diff --git a/app-mobilephone/gammu/Manifest b/app-mobilephone/gammu/Manifest
index 20933dc2e75a..2570a5c810c7 100644
--- a/app-mobilephone/gammu/Manifest
+++ b/app-mobilephone/gammu/Manifest
@@ -1,6 +1,19 @@
-MD5 ab54d265a942ab9ee05aad7f0c63ae7a ChangeLog 3380
-MD5 604ce9e4b73f363078b051036e766cc6 gammu-1.00.04.ebuild 1527
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 d9adbf5a223a11c58145784214e64413 gammu-1.01.0-r1.ebuild 1657
MD5 e3e6f3795324467bd398bacc795372f0 gammu-1.01.0.ebuild 1572
+MD5 604ce9e4b73f363078b051036e766cc6 gammu-1.00.04.ebuild 1527
+MD5 e46220e7dd299f462b721f7506e4df81 ChangeLog 3579
MD5 e161c5ddb0e2ddbe68a21690f41e90e1 metadata.xml 227
-MD5 bf5ffb3fb824c41689a9cbd8b634cd33 files/digest-gammu-1.00.04 65
+MD5 c99ecf9019c20984a405aeea6c2c6e60 files/gammu-1.01.0-caller.patch 1021
MD5 fe619bd2a9bf0758cba9ac45162c8758 files/digest-gammu-1.01.0 64
+MD5 bf5ffb3fb824c41689a9cbd8b634cd33 files/digest-gammu-1.00.04 65
+MD5 fe619bd2a9bf0758cba9ac45162c8758 files/digest-gammu-1.01.0-r1 64
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCx5cyNSP4Vda7IdsRAr87AJwPxPqziwcPe6psX3JDGKxjYzN1cQCePOMy
+grvXV29jEV6Av31+KtS70Gg=
+=kQZl
+-----END PGP SIGNATURE-----
diff --git a/app-mobilephone/gammu/files/digest-gammu-1.01.0-r1 b/app-mobilephone/gammu/files/digest-gammu-1.01.0-r1
new file mode 100644
index 000000000000..ff12441628c4
--- /dev/null
+++ b/app-mobilephone/gammu/files/digest-gammu-1.01.0-r1
@@ -0,0 +1 @@
+MD5 1ae9d7d51158c9f0cb5d3b25e7e7e1e1 gammu-1.01.0.tar.gz 860546
diff --git a/app-mobilephone/gammu/files/gammu-1.01.0-caller.patch b/app-mobilephone/gammu/files/gammu-1.01.0-caller.patch
new file mode 100644
index 000000000000..66139a661206
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-1.01.0-caller.patch
@@ -0,0 +1,26 @@
+--- gammu/gammu.c.orig 2005-06-30 09:38:18.228171067 +0200
++++ gammu/gammu.c 2005-06-30 09:40:11.892838077 +0200
+@@ -436,9 +436,9 @@
+ GSM_Terminate();
+ }
+
+-GSM_Bitmap caller[5];
++GSM_Bitmap caller[6];
+ GSM_AllRingtonesInfo Info = {0, NULL};
+-bool callerinit[5] = {false, false, false, false, false};
++bool callerinit[6] = {false, false, false, false, false, false};
+ bool ringinit = false;
+
+ static void PrintMemoryEntry(GSM_MemoryEntry *entry)
+@@ -498,6 +498,11 @@
+ case PBK_Text_Custom4 : printmsg("Custom text 4 "); break;
+ case PBK_Caller_Group :
+ unknown = true;
++ if (entry->Entries[i].Number > 5) {
++ printmsg("Caller group : \"%d\"\n",entry->Entries[i].Number);
++ printmsgerr("Caller group number too high, please increase buffer in sources!\n");
++ break;
++ }
+ if (!callerinit[entry->Entries[i].Number]) {
+ caller[entry->Entries[i].Number].Type = GSM_CallerGroupLogo;
+ caller[entry->Entries[i].Number].Location = entry->Entries[i].Number;
diff --git a/app-mobilephone/gammu/gammu-1.01.0-r1.ebuild b/app-mobilephone/gammu/gammu-1.01.0-r1.ebuild
new file mode 100644
index 000000000000..9f0edb3e505b
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.01.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.01.0-r1.ebuild,v 1.1 2005/07/03 07:43:27 mrness Exp $
+
+inherit eutils
+
+MY_MAJOR_VER=${PV:0:3}
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+SRC_URI="http://www.mwiacek.com/zips/gsm/${PN}/stable/${MY_MAJOR_VER/./_}x/${P}.tar.gz"
+HOMEPAGE="http://www.gammu.net/projects/gammu.php"
+
+IUSE="bluetooth irda mysql nls ssl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="mysql? ( dev-db/mysql )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ bluetooth? ( net-wireless/bluez-libs )"
+
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-caller.patch
+}
+
+src_compile() {
+ local myconf
+ use bluetooth && myconf="${myconf} --with-bluedir=/usr/lib" \
+ || myconf="${myconf} --disable-bluefbus --disable-blueobex --disable-bluephonet --disable-blueat --disable-bluerfsearch --disable-fbusblue"
+ use irda || myconf="${myconf} --disable-irdaat --disable-irdaphonet"
+ sed -e 's:-lbluetooth -lsdp:-lbluetooth:g' \
+ -i ${S}/cfg/autoconf/configure.in
+ econf \
+ `use_enable nls` \
+ --prefix=/usr \
+ --enable-cb \
+ --enable-7110incoming \
+ --enable-6210calendar \
+ ${myconf} || die "configure failed"
+
+ sed -e 's:-lz -pthread:-lz -lpthread -lssl:g' \
+ -i ${S}/cfg/Makefile.cfg
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} installlib || die "install failed"
+ doman docs/docs/english/gammu.1
+ mv ${D}/usr/share/doc/${PN} ${D}/usr/share/doc/${P}
+}