summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-03 14:15:17 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-03 14:15:17 +0000
commite1c7cfc22c24474df142824d925cd7eed28c0fc8 (patch)
tree529a7abbd2f33f8fe764f6601871c6685883ef5a /app-text/pstotext/files
parentadd ~arm, bug #336158 (diff)
downloadhistorical-e1c7cfc22c24474df142824d925cd7eed28c0fc8.tar.gz
historical-e1c7cfc22c24474df142824d925cd7eed28c0fc8.tar.bz2
historical-e1c7cfc22c24474df142824d925cd7eed28c0fc8.zip
QA, removed old, respecting LDFLAGS/CFLAGS/CC, 335595
Package-Manager: portage-2.2_rc88/cvs/Linux x86_64
Diffstat (limited to 'app-text/pstotext/files')
-rw-r--r--app-text/pstotext/files/1.9-flags.patch36
-rw-r--r--app-text/pstotext/files/pstotext-1.8g-dsafer.patch14
2 files changed, 36 insertions, 14 deletions
diff --git a/app-text/pstotext/files/1.9-flags.patch b/app-text/pstotext/files/1.9-flags.patch
new file mode 100644
index 000000000000..6f3c9b68d82c
--- /dev/null
+++ b/app-text/pstotext/files/1.9-flags.patch
@@ -0,0 +1,36 @@
+diff --git a/Makefile b/Makefile
+index 551e3b8..1d55ebe 100644
+--- a/Makefile
++++ b/Makefile
+@@ -9,7 +9,7 @@
+ # commenting out the includes of ptotdll.h in ptotdll.c and main.c.
+ # PMcJ 6 Sep 96
+
+-CC=gcc
++CC ?= gcc
+ #CC=cc -std
+
+ BUNDLE = ocr.h rot270.h rot90.h
+@@ -17,18 +17,18 @@ BUNDLE = ocr.h rot270.h rot90.h
+ all: pstotext
+
+ main.o: main.c ptotdll.h bundle.h ocr.h rot270.h rot90.h
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ ptotdll.o: ptotdll.c ptotdll.h
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ pstotext: bundle.o main.o ptotdll.o
+- $(CC) -o pstotext main.o bundle.o ptotdll.o -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o pstotext main.o bundle.o ptotdll.o -lm
+
+ .SUFFIXES: .ps
+
+ .c.o:
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ # "Bundle" an Ascii file.
+ .ps.h:
diff --git a/app-text/pstotext/files/pstotext-1.8g-dsafer.patch b/app-text/pstotext/files/pstotext-1.8g-dsafer.patch
deleted file mode 100644
index 06e67e897cba..000000000000
--- a/app-text/pstotext/files/pstotext-1.8g-dsafer.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- pstotext-1.9/main.c~ 2005-06-02 15:42:33.754177096 +0200
-+++ pstotext-1.9/main.c 2005-06-02 15:45:20.412084016 +0200
-@@ -231,9 +231,9 @@
- sprintf(
- gs_cmdline,
- #ifdef VMS
-- "%s -r72 \"-dNODISPLAY\" \"-dFIXEDMEDIA\" \"-dDELAYBIND\" \"-dWRITESYSTEMDICT\" %s \"-dNOPAUSE\" %s %s %s",
-+ "%s -r72 \"-dNODISPLAY\" \"-dFIXEDMEDIA\" \"-dDELAYBIND\" \"-dWRITESYSTEMDICT\" %s \"-dNOPAUSE\" \"-dSAFER\" %s %s %s",
- #else
-- "%s -r72 -dNODISPLAY -dFIXEDMEDIA -dDELAYBIND -dWRITESYSTEMDICT %s -dNOPAUSE %s %s %s",
-+ "%s -r72 -dNODISPLAY -dFIXEDMEDIA -dDELAYBIND -dWRITESYSTEMDICT %s -dNOPAUSE -dSAFER %s %s %s",
- #endif
- gs_cmd,
- (debug ? "" : "-q"),