summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2014-03-04 16:02:17 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2014-03-04 16:02:17 +0000
commitf2e0f886254e5c01203edb2ebebfb293865410b1 (patch)
tree02d59f561cecc2f3dd140ece8171708bffc1d0fd /dev-haskell/text/text-1.1.0.0.ebuild
parentnew package (diff)
downloadhistorical-f2e0f886254e5c01203edb2ebebfb293865410b1.tar.gz
historical-f2e0f886254e5c01203edb2ebebfb293865410b1.tar.bz2
historical-f2e0f886254e5c01203edb2ebebfb293865410b1.zip
bump up to 1.1
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xEAD50D64D8D3571A!
Diffstat (limited to 'dev-haskell/text/text-1.1.0.0.ebuild')
-rw-r--r--dev-haskell/text/text-1.1.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/text/text-1.1.0.0.ebuild b/dev-haskell/text/text-1.1.0.0.ebuild
new file mode 100644
index 000000000000..a354ea8984a1
--- /dev/null
+++ b/dev-haskell/text/text-1.1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-1.1.0.0.ebuild,v 1.1 2014/03/04 16:02:16 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type."
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="developer"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/deepseq
+ >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4
+ dev-haskell/random
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-hunit-0.2
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag developer developer)
+}