summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-04-15 22:24:25 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-04-15 22:24:25 +0000
commit11f031d8f8a7a2270eff40a1a5e479209b455320 (patch)
treecdfebe950790364e6ad1f5baa60ff37953d5f677 /dev-java/java-sdk-docs/java-sdk-docs-1.8.0.45.ebuild
parentsci-physics/lammps: Removing obsolete patch. (diff)
downloadhistorical-11f031d8f8a7a2270eff40a1a5e479209b455320.tar.gz
historical-11f031d8f8a7a2270eff40a1a5e479209b455320.tar.bz2
historical-11f031d8f8a7a2270eff40a1a5e479209b455320.zip
Version bump.
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0x9C6D7DE4
Diffstat (limited to 'dev-java/java-sdk-docs/java-sdk-docs-1.8.0.45.ebuild')
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.45.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.45.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.45.ebuild
new file mode 100644
index 000000000000..956dc94e7649
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.45.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.45.ebuild,v 1.1 2015/04/15 22:21:33 chewi Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="app-arch/unzip:0"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}