summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-01-28 04:59:12 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-01-28 04:59:12 +0000
commit6c106f32cbf1fd99759a96b1260805180acea1f5 (patch)
tree8bf7e45c4a14a8f2666b35c69e418771c4e853d3 /dev-lisp/cl-pxmlutils
parentfix bug #33718, and version bump to new openldap (diff)
downloadhistorical-6c106f32cbf1fd99759a96b1260805180acea1f5.tar.gz
historical-6c106f32cbf1fd99759a96b1260805180acea1f5.tar.bz2
historical-6c106f32cbf1fd99759a96b1260805180acea1f5.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-pxmlutils')
-rw-r--r--dev-lisp/cl-pxmlutils/ChangeLog10
-rw-r--r--dev-lisp/cl-pxmlutils/Manifest5
-rw-r--r--dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild38
-rw-r--r--dev-lisp/cl-pxmlutils/files/0.0.9-allegro-declare-gentoo.patch24
-rw-r--r--dev-lisp/cl-pxmlutils/files/digest-cl-pxmlutils-0.0.91
-rw-r--r--dev-lisp/cl-pxmlutils/files/pxmlutils.asd26
-rw-r--r--dev-lisp/cl-pxmlutils/metadata.xml10
7 files changed, 114 insertions, 0 deletions
diff --git a/dev-lisp/cl-pxmlutils/ChangeLog b/dev-lisp/cl-pxmlutils/ChangeLog
new file mode 100644
index 000000000000..d95c320845f4
--- /dev/null
+++ b/dev-lisp/cl-pxmlutils/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-pxmlutils
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pxmlutils/ChangeLog,v 1.1 2004/01/28 04:59:11 mkennedy Exp $
+
+*cl-pxmlutils-0.0.9 (27 Jan 2004)
+
+ 27 Jan 2004; <mkennedy@gentoo.org> cl-pxmlutils-0.0.9.ebuild, metadata.xml,
+ files/0.0.9-allegro-declare-gentoo.patch, files/pxmlutils.asd:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-pxmlutils/Manifest b/dev-lisp/cl-pxmlutils/Manifest
new file mode 100644
index 000000000000..310f84cefbca
--- /dev/null
+++ b/dev-lisp/cl-pxmlutils/Manifest
@@ -0,0 +1,5 @@
+MD5 9ae9d971b6881361d91a543c42c457f4 cl-pxmlutils-0.0.9.ebuild 901
+MD5 e2d5eef92b6cb67f76d8cd0e79fd8904 cl-pxmlutils-0.0.9.ebuild~ 901
+MD5 4a244585c497b40153c4f9c808e061ad metadata.xml 393
+MD5 ceb6b50f3c4cfb959b2888276d60b2d3 files/digest-cl-pxmlutils-0.0.8 69
+MD5 0329a00fe1ea73afb97d93a34d3c91dc files/digest-cl-pxmlutils-0.0.9 67
diff --git a/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild b/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild
new file mode 100644
index 000000000000..4edf20dcd0c8
--- /dev/null
+++ b/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pxmlutils/cl-pxmlutils-0.0.9.ebuild,v 1.1 2004/01/28 04:59:11 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Portable version of Franz's xmlutils."
+HOMEPAGE="http://www.common-lisp.net/project/bese/pxmlutils.html"
+SRC_URI="ftp://ftp.common-lisp.net/pub/project/bese/pxmlutils/pxmlutils_${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/cl-acl-compat
+ virtual/commonlisp"
+
+S=${WORKDIR}/pxmlutils_${PV}
+
+CLPACKAGE=pxmlutils
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-allegro-declare-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install ${FILESDIR}/pxmlutils.asd pxml*.cl
+ common-lisp-system-symlink
+ dodoc ChangeLog README pxml.{htm,txt}
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-pxmlutils/files/0.0.9-allegro-declare-gentoo.patch b/dev-lisp/cl-pxmlutils/files/0.0.9-allegro-declare-gentoo.patch
new file mode 100644
index 000000000000..eda6588d82d4
--- /dev/null
+++ b/dev-lisp/cl-pxmlutils/files/0.0.9-allegro-declare-gentoo.patch
@@ -0,0 +1,24 @@
+Common subdirectories: pxmlutils_0.0.9.original/.arch-ids and pxmlutils_0.0.9/.arch-ids
+diff -u pxmlutils_0.0.9.original/pxml3.cl pxmlutils_0.0.9/pxml3.cl
+--- pxmlutils_0.0.9.original/pxml3.cl 2004-01-15 10:57:53.000000000 -0600
++++ pxmlutils_0.0.9/pxml3.cl 2004-01-27 21:49:23.620276504 -0600
+@@ -146,7 +146,7 @@
+
+ (defun next-dtd-token (tokenbuf
+ external include-count external-callback)
+- (declare (:fbound parse-default-value) (optimize (speed 3) (safety 1)))
++ (declare #+allegro (:fbound parse-default-value) (optimize (speed 3) (safety 1)))
+ (macrolet ((add-to-entity-buf (entity-symbol p-value)
+ `(progn
+ (push (make-tokenbuf :cur 0 :max (length ,p-value) :data ,p-value)
+@@ -2395,7 +2395,7 @@
+ ))
+
+ (defun external-param-reference (tokenbuf old-coll external-callback)
+- (declare (:fbound next-token) (ignorable old-coll) (optimize (speed 3) (safety 1)))
++ (declare #+allegro (:fbound next-token) (ignorable old-coll) (optimize (speed 3) (safety 1)))
+ (setf (iostruct-seen-parameter-reference tokenbuf) t)
+ (macrolet ((add-to-entity-buf (entity-symbol p-value)
+ `(progn
+Only in pxmlutils_0.0.9: pxml3.cl~
+Common subdirectories: pxmlutils_0.0.9.original/{arch} and pxmlutils_0.0.9/{arch}
diff --git a/dev-lisp/cl-pxmlutils/files/digest-cl-pxmlutils-0.0.9 b/dev-lisp/cl-pxmlutils/files/digest-cl-pxmlutils-0.0.9
new file mode 100644
index 000000000000..31e8096f5273
--- /dev/null
+++ b/dev-lisp/cl-pxmlutils/files/digest-cl-pxmlutils-0.0.9
@@ -0,0 +1 @@
+MD5 c912a48167246d275fdc548f150ccbd4 pxmlutils_0.0.9.tar.gz 124191
diff --git a/dev-lisp/cl-pxmlutils/files/pxmlutils.asd b/dev-lisp/cl-pxmlutils/files/pxmlutils.asd
new file mode 100644
index 000000000000..abac415a1e27
--- /dev/null
+++ b/dev-lisp/cl-pxmlutils/files/pxmlutils.asd
@@ -0,0 +1,26 @@
+;;;; -*- lisp -*-
+
+;; This is the same as the ASDF as the one distributed with pxmlutils.
+;; The only difference is that phtml.cl has been omitted
+;; (dev-lisp/cl-phtml already provides this from the Portable Allegro
+;; Server project) -- Matthew Kennedy <mkennedy@gentoo.org>
+
+(defpackage :pxmlutils.system
+ (:use :common-lisp
+ :asdf))
+
+(in-package :pxmlutils.system)
+
+(defclass file.cl (cl-source-file)
+ ())
+
+(defmethod source-file-type ((f file.cl) (m module))
+ (declare (ignore f m))
+ "cl")
+
+(defsystem :pxmlutils
+ :components ((:file.cl "pxml0")
+ (:file.cl "pxml1" :depends-on ("pxml0"))
+ (:file.cl "pxml2" :depends-on ("pxml1"))
+ (:file.cl "pxml3" :depends-on ("pxml2")))
+ :depends-on (:acl-compat))
diff --git a/dev-lisp/cl-pxmlutils/metadata.xml b/dev-lisp/cl-pxmlutils/metadata.xml
new file mode 100644
index 000000000000..d0b3bb0c78ed
--- /dev/null
+++ b/dev-lisp/cl-pxmlutils/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+Portable version of Franz's xmlutils. The major difference between
+Franz Inc.'s version and this port is the removal of UNICODE support.
+This package contains XML and HTML parsing libraries.
+</longdescription>
+</pkgmetadata>