summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-05 07:30:08 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-05 07:30:08 +0000
commit1e9f6566e26ee9b56cd64f3be578d60ca40e080f (patch)
treedbf51b38bc259b6c42bff0f47f0ef0462225c079 /dev-php/mod_php
parentAdded patch to fix compilation in gcc2 provided in bug #40370 by Tristan Hend... (diff)
downloadhistorical-1e9f6566e26ee9b56cd64f3be578d60ca40e080f.tar.gz
historical-1e9f6566e26ee9b56cd64f3be578d60ca40e080f.tar.bz2
historical-1e9f6566e26ee9b56cd64f3be578d60ca40e080f.zip
amd64 fix #35956
Diffstat (limited to 'dev-php/mod_php')
-rw-r--r--dev-php/mod_php/ChangeLog5
-rw-r--r--dev-php/mod_php/files/mod_php-4.3.4-amd64hack.diff28
-rw-r--r--dev-php/mod_php/mod_php-4.3.4-r3.ebuild7
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index bfc13882f179..aeb5de750f40 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.123 2004/01/31 22:56:37 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.124 2004/02/05 07:25:17 vapier Exp $
+
+ 05 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add amd64 patch #35956 by Ryan C. Gordon.
31 Jan 2004; Stuart Herbert <stuart@gentoo.org> files/mod_php-4.3.4-r3.diff:
Additional holes added to the patch
diff --git a/dev-php/mod_php/files/mod_php-4.3.4-amd64hack.diff b/dev-php/mod_php/files/mod_php-4.3.4-amd64hack.diff
new file mode 100644
index 000000000000..2e36b25b9a08
--- /dev/null
+++ b/dev-php/mod_php/files/mod_php-4.3.4-amd64hack.diff
@@ -0,0 +1,28 @@
+--- ltmain.sh_orig 2004-01-29 02:00:07.202890120 -0500
++++ ltmain.sh 2004-01-29 02:05:30.628721920 -0500
+@@ -2586,6 +2586,12 @@
+ set dummy $deplibs_check_method
+ file_magic_regex=`expr "$deplibs_check_method" : "$2 \(.*\)"`
+ for a_deplib in $deplibs; do
++
++ if test "x$a_deplib" = "x-lc-client" ; then
++ newdeplibs="$newdeplibs $a_deplib"
++ continue
++ fi
++
+ name="`expr $a_deplib : '-l\(.*\)'`"
+ # If $name is empty we are operating on a -L argument.
+ if test -n "$name" && test "$name" != "0"; then
+@@ -2645,6 +2651,12 @@
+ set dummy $deplibs_check_method
+ match_pattern_regex=`expr "$deplibs_check_method" : "$2 \(.*\)"`
+ for a_deplib in $deplibs; do
++
++ if test "x$a_deplib" = "x-lc-client" ; then
++ newdeplibs="$newdeplibs $a_deplib"
++ continue
++ fi
++
+ name="`expr $a_deplib : '-l\(.*\)'`"
+ # If $name is empty we are operating on a -L argument.
+ if test -n "$name" && test "$name" != "0"; then
diff --git a/dev-php/mod_php/mod_php-4.3.4-r3.ebuild b/dev-php/mod_php/mod_php-4.3.4-r3.ebuild
index e81e8c6fbdfa..06c0672db21d 100644
--- a/dev-php/mod_php/mod_php-4.3.4-r3.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.4-r3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.4-r3.ebuild,v 1.3 2004/02/05 04:05:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.4-r3.ebuild,v 1.4 2004/02/05 07:25:17 vapier Exp $
IUSE="${IUSE} apache2"
DESCRIPTION="Apache module for PHP"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~ia64"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~ia64 ~amd64"
detectapache() {
local domsg=
@@ -66,6 +66,9 @@ src_unpack() {
multiinstwarn
detectapache domsg
php-sapi_src_unpack
+ if [ "${ARCH}" == "amd64" ] ; then
+ epatch ${FILESDIR}/${P}-amd64hack.diff
+ fi
# bug fix for security problem - bug #39952
epatch ${FILESDIR}/mod_php-4.3.4-r3.diff