summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-29 17:50:03 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-29 17:50:03 +0000
commit6d2c03a767e66e59ebc20dfd51c18a50efa838ec (patch)
treeb47984478e769158ae3686833e2d94f62e645bb2 /dev-php/smarty
parentAdded core-dir. Closes #29880. (diff)
downloadhistorical-6d2c03a767e66e59ebc20dfd51c18a50efa838ec.tar.gz
historical-6d2c03a767e66e59ebc20dfd51c18a50efa838ec.tar.bz2
historical-6d2c03a767e66e59ebc20dfd51c18a50efa838ec.zip
Added core-dir. Closes #29880.
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/Manifest5
-rw-r--r--dev-php/smarty/files/digest-smarty-2.6.0_rc1-r11
-rw-r--r--dev-php/smarty/smarty-2.6.0_rc1-r1.ebuild35
3 files changed, 39 insertions, 2 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index 859c01763ced..948cf23bde77 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,7 +1,8 @@
-MD5 bc8dad0ec29de2f82f1106e8923d3b0f ChangeLog 457
+MD5 2d9a83322371b68fd1246365edcb8a22 ChangeLog 609
MD5 43d5731b78f6d99e3ff4791b1ce3dc25 smarty-2.5.0.ebuild 996
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
-MD5 4e2683fc38e152b11075d3dd9324eb81 smarty-2.6.0_rc1-r1.ebuild 1102
+MD5 4f6183b5f3503fa3dd69391a0eba19c8 smarty-2.6.0_rc1.ebuild 918
+MD5 6b172805689772956bcf7ef25230f510 smarty-2.6.0_rc1-r1.ebuild 1109
MD5 74ae938ca9097670a89c5f2ff6ad28f8 files/digest-smarty-2.5.0 133
MD5 d2e1f2edbf3fa357f3fabb573b96d430 files/digest-smarty-2.6.0_rc1 68
MD5 d2e1f2edbf3fa357f3fabb573b96d430 files/digest-smarty-2.6.0_rc1-r1 68
diff --git a/dev-php/smarty/files/digest-smarty-2.6.0_rc1-r1 b/dev-php/smarty/files/digest-smarty-2.6.0_rc1-r1
new file mode 100644
index 000000000000..e84ce5c9365e
--- /dev/null
+++ b/dev-php/smarty/files/digest-smarty-2.6.0_rc1-r1
@@ -0,0 +1 @@
+MD5 df5172af7035f64a2c9e075cf4167733 Smarty-2.6.0-RC1.tar.gz 119551
diff --git a/dev-php/smarty/smarty-2.6.0_rc1-r1.ebuild b/dev-php/smarty/smarty-2.6.0_rc1-r1.ebuild
new file mode 100644
index 000000000000..3549ba50f8d2
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.0_rc1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.0_rc1-r1.ebuild,v 1.1 2003/09/29 17:49:57 mholzer Exp $
+
+MY_P=Smarty-${PV/_rc/-RC}
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://smarty.php.net/"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha arm hppa mips ppc sparc x86"
+IUSE="doc"
+DEPEND="virtual/php"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodoc [A-Z]*
+ insinto /usr/lib/php/Smarty
+ doins libs/*
+ insinto /usr/lib/php/Smarty/core
+ doins libs/core/*
+ insinto /usr/lib/php/Smarty/plugins
+ doins libs/plugins/*
+}
+
+pkg_postinst() {
+ einfo "Smarty has been installed in /usr/lib/php/Smarty."
+ einfo "To use it in your scripts, either"
+ einfo "1. define(SMARTY_DIR, \"/usr/lib/php/Smarty\") in your scripts, or"
+ einfo "2. add /usr/lib/php/Smarty to includes= in /etc/php4/php.ini"
+ einfo
+ einfo "You may have to clean up your \"compile_dir\" and \"cache_dir\""
+ einfo "in order to get Smarty working correctly."
+}