summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 23:16:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 23:16:44 +0000
commit1c44abe829c69236022619be28fa3972ad8c1b02 (patch)
treebe8731399cc9ae226de5dcc7291ce0d7093f490d /dev-python/pudge
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-1c44abe829c69236022619be28fa3972ad8c1b02.tar.gz
historical-1c44abe829c69236022619be28fa3972ad8c1b02.tar.bz2
historical-1c44abe829c69236022619be28fa3972ad8c1b02.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-14471-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pudge')
-rw-r--r--dev-python/pudge/ChangeLog8
-rw-r--r--dev-python/pudge/pudge-0.1.3.ebuild15
2 files changed, 16 insertions, 7 deletions
diff --git a/dev-python/pudge/ChangeLog b/dev-python/pudge/ChangeLog
index 34ad8eeb1226..2e152629176a 100644
--- a/dev-python/pudge/ChangeLog
+++ b/dev-python/pudge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pudge
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pudge/ChangeLog,v 1.5 2007/07/04 20:16:09 lucass Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pudge/ChangeLog,v 1.6 2009/10/01 23:16:44 arfrever Exp $
+
+ 02 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pudge-0.1.3.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
04 Jul 2007; Lukasz Strzygowski <lucass@gentoo.org> -pudge-0.1.2.ebuild,
pudge-0.1.3.ebuild:
diff --git a/dev-python/pudge/pudge-0.1.3.ebuild b/dev-python/pudge/pudge-0.1.3.ebuild
index 11640cd90e09..e6e56efac0d2 100644
--- a/dev-python/pudge/pudge-0.1.3.ebuild
+++ b/dev-python/pudge/pudge-0.1.3.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pudge/pudge-0.1.3.ebuild,v 1.3 2007/07/04 20:16:09 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pudge/pudge-0.1.3.ebuild,v 1.4 2009/10/01 23:16:44 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -17,12 +20,14 @@ RDEPEND="dev-python/docutils
>=dev-python/kid-0.9.5"
DEPEND="dev-python/setuptools
doc? ( ${RDEPEND} )"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
src_install() {
distutils_src_install
- if use doc ; then
- einfo "Generating docs as requested..."
- ./bin/pudge --modules=pudge --documents=doc/index.rst --dest=doc/html
+
+ if use doc; then
+ einfo "Generation of documentation"
+ ./bin/pudge --modules=pudge --documents=doc/index.rst --dest=doc/html || die "Generation of documentation failed"
dohtml -r doc/html/*
fi
}