summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-09 09:13:24 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-09 09:13:24 +0000
commitc5dfbbac1816aac72c5c4a286cf3a390ab88f3e7 (patch)
treeb15c54ec4d4939fb79d4400e0f5bb6cfa0e1b1e9 /dev-python
parentx86 stable wrt bug #373573 (diff)
downloadhistorical-c5dfbbac1816aac72c5c4a286cf3a390ab88f3e7.tar.gz
historical-c5dfbbac1816aac72c5c4a286cf3a390ab88f3e7.tar.bz2
historical-c5dfbbac1816aac72c5c4a286cf3a390ab88f3e7.zip
Bump
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/scripttest/ChangeLog9
-rw-r--r--dev-python/scripttest/scripttest-1.2.ebuild27
-rw-r--r--dev-python/spyder/ChangeLog7
-rw-r--r--dev-python/spyder/spyder-2.1.7.ebuild61
-rw-r--r--dev-python/sqlobject/ChangeLog9
-rw-r--r--dev-python/sqlobject/sqlobject-1.2.2.ebuild45
-rw-r--r--dev-python/virtualenvwrapper/ChangeLog8
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild36
8 files changed, 196 insertions, 6 deletions
diff --git a/dev-python/scripttest/ChangeLog b/dev-python/scripttest/ChangeLog
index a0f9a5d04019..fcb225469dcf 100644
--- a/dev-python/scripttest/ChangeLog
+++ b/dev-python/scripttest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/scripttest
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scripttest/ChangeLog,v 1.1 2011/09/03 18:10:45 djc Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scripttest/ChangeLog,v 1.2 2012/03/09 09:13:24 patrick Exp $
+
+*scripttest-1.2 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org> +scripttest-1.2.ebuild:
+ Bump
*scripttest-1.1.1 (03 Sep 2011)
diff --git a/dev-python/scripttest/scripttest-1.2.ebuild b/dev-python/scripttest/scripttest-1.2.ebuild
new file mode 100644
index 000000000000..66ae1ee7ac02
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scripttest/scripttest-1.2.ebuild,v 1.1 2012/03/09 09:13:24 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="ScriptTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="http://pythonpaste.org/scripttest/ http://pypi.python.org/pypi/ScriptTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index 69432f6e6824..8c60afc8ef6e 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.25 2012/02/25 01:58:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.26 2012/03/09 09:12:03 patrick Exp $
+
+*spyder-2.1.7 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org> +spyder-2.1.7.ebuild:
+ Bump
25 Feb 2012; Patrick Lauer <patrick@gentoo.org> spyder-2.1.2.ebuild,
spyder-2.1.6.ebuild:
diff --git a/dev-python/spyder/spyder-2.1.7.ebuild b/dev-python/spyder/spyder-2.1.7.ebuild
new file mode 100644
index 000000000000..bef9ade1604f
--- /dev/null
+++ b/dev-python/spyder/spyder-2.1.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.7.ebuild,v 1.1 2012/03/09 09:12:03 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
+
+RDEPEND=">=dev-python/PyQt4-4.4[webkit]
+ ipython? ( dev-python/ipython )
+ matplotlib? ( dev-python/matplotlib )
+ numpy? ( dev-python/numpy )
+ pep8? ( dev-python/pep8 )
+ pyflakes? ( >=dev-python/pyflakes-0.3 )
+ pylint? ( dev-python/pylint )
+ rope? ( >=dev-python/rope-0.9.3 )
+ scipy? ( sci-libs/scipy )
+ sphinx? ( dev-python/sphinx )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+PYTHON_MODNAME="spyderlib spyderplugins"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-2.1.2-disable_sphinx_dependency.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="build-$(PYTHON -f --ABI)" \
+ sphinx-build doc doc_output || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ doicon spyderlib/images/spyder.svg || die
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+ if use doc; then
+ pushd doc_output > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}
diff --git a/dev-python/sqlobject/ChangeLog b/dev-python/sqlobject/ChangeLog
index 0041dbbde566..746b493d6c86 100644
--- a/dev-python/sqlobject/ChangeLog
+++ b/dev-python/sqlobject/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sqlobject
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlobject/ChangeLog,v 1.45 2011/12/25 10:11:29 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlobject/ChangeLog,v 1.46 2012/03/09 09:10:42 patrick Exp $
+
+*sqlobject-1.2.2 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org> +sqlobject-1.2.2.ebuild:
+ Bump
*sqlobject-1.2.0 (25 Dec 2011)
diff --git a/dev-python/sqlobject/sqlobject-1.2.2.ebuild b/dev-python/sqlobject/sqlobject-1.2.2.ebuild
new file mode 100644
index 000000000000..3f2f90f56463
--- /dev/null
+++ b/dev-python/sqlobject/sqlobject-1.2.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlobject/sqlobject-1.2.2.ebuild,v 1.1 2012/03/09 09:10:42 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="SQLObject"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Object-Relational Manager, aka database wrapper"
+HOMEPAGE="http://sqlobject.org/ http://pypi.python.org/pypi/SQLObject"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc firebird mysql postgres sqlite"
+
+RDEPEND=">=dev-python/formencode-0.2.2
+ firebird? ( >=dev-python/kinterbasdb-3.0.2 )
+ mysql? ( >=dev-python/mysql-python-0.9.2-r1 )
+ postgres? ( dev-python/psycopg )
+ sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite ) )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd docs
+ dodoc *.txt || die "dodoc failed"
+ dohtml -r presentation-2004-11 || die "dohtml failed"
+ insinto /usr/share/doc/${PF}
+ doins -r europython || die "doins failed"
+ popd
+ fi
+}
diff --git a/dev-python/virtualenvwrapper/ChangeLog b/dev-python/virtualenvwrapper/ChangeLog
index 1711b4d2ccd1..8011f374de2c 100644
--- a/dev-python/virtualenvwrapper/ChangeLog
+++ b/dev-python/virtualenvwrapper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/virtualenvwrapper
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/ChangeLog,v 1.1 2012/02/14 21:00:24 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/ChangeLog,v 1.2 2012/03/09 09:06:34 patrick Exp $
+
+*virtualenvwrapper-3.0.1 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org>
+ +virtualenvwrapper-3.0.1.ebuild:
+ Bump
*virtualenvwrapper-3.0 (14 Feb 2012)
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild
new file mode 100644
index 000000000000..6be1d4c62bb0
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild,v 1.1 2012/03/09 09:06:34 patrick Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+inherit python
+
+DESCRIPTION="virtualenvwrapper is a set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="http://www.doughellmann.com/projects/virtualenvwrapper http://pypi.python.org/pypi/virtualenvwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/virtualenv"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/tox )"
+
+#src_test() {
+# testing() {
+# PYTHON_MAJOR="$(python_get_version --major)"
+# PYTHON_MINOR="$(python_get_version --minor)"
+# cp ${FILESDIR}/tox.ini .
+# export TMPDIR=${T}
+# tox -e py${PYTHON_MAJOR}${PYTHON_MINOR} tests/test_cp.sh
+# }
+# python_execute_function testing
+#}