summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-24 19:19:37 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-24 19:19:37 +0000
commitc9991d2964b6c4fd3d461f608801da7c9b644e7c (patch)
treeecd013112c486c2443d3c89503da254ed605623b /dev-python
parentMask app-misc/gwine for removal (diff)
downloadhistorical-c9991d2964b6c4fd3d461f608801da7c9b644e7c.tar.gz
historical-c9991d2964b6c4fd3d461f608801da7c9b644e7c.tar.bz2
historical-c9991d2964b6c4fd3d461f608801da7c9b644e7c.zip
Delete older ebuild.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cython/cython-0.12.ebuild62
-rw-r--r--dev-python/cython/files/cython-0.12-report_test_failures.patch17
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/cython/cython-0.12.ebuild b/dev-python/cython/cython-0.12.ebuild
deleted file mode 100644
index 3936edf564c0..000000000000
--- a/dev-python/cython/cython-0.12.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.12.ebuild,v 1.8 2010/02/07 20:47:14 pva Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils distutils flag-o-matic
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/.}"
-
-DESCRIPTION="A language for writing Python extension modules based on pyrex"
-HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
- http://www.cython.org/release/${MY_P}.tar.gz"
-
-LICENSE="PSF-2.4"
-SLOT="0"
-KEYWORDS="amd64 ~arm hppa ~ia64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples"
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="${MY_PN} pyximport"
-DOCS="ToDo.txt USAGE.txt"
-
-src_prepare() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/${P}-report_test_failures.patch"
-}
-
-src_test() {
- testing() {
- # Tests fail with Python 3 due to bug in Python.
- # http://bugs.python.org/issue7173
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
- rm -fr BUILD
- # Tests sometimes hang with forking enabled.
- "$(PYTHON)" runtests.py --no-fork -vv
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- # '-A c' is for ignoring of Doc/primes.c.
- use doc && dohtml -A c -r Doc/*
-
- if use examples; then
- # Demos/ has files with .so,~ suffixes.
- # So we have to specify precisely what to install.
- insinto /usr/share/doc/${PF}/examples
- doins Demos/Makefile* Demos/setup.py Demos/*.{py,pyx}
- fi
-}
diff --git a/dev-python/cython/files/cython-0.12-report_test_failures.patch b/dev-python/cython/files/cython-0.12-report_test_failures.patch
deleted file mode 100644
index 07e000b899d1..000000000000
--- a/dev-python/cython/files/cython-0.12-report_test_failures.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- runtests.py
-+++ runtests.py
-@@ -856,7 +856,7 @@
- os.path.join(sys.prefix, 'lib', 'python'+sys.version[:3], 'test'),
- 'pyregr'))
-
-- unittest.TextTestRunner(verbosity=options.verbosity).run(test_suite)
-+ result = unittest.TextTestRunner(verbosity=options.verbosity).run(test_suite)
-
- if options.coverage:
- coverage.stop()
-@@ -875,3 +875,5 @@
- if options.with_refnanny:
- import refnanny
- sys.stderr.write("\n".join([repr(x) for x in refnanny.reflog]))
-+
-+ sys.exit(not result.wasSuccessful())